summaryrefslogtreecommitdiff
path: root/src/schema.sql
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-01-24 19:47:43 +0000
committerChristopher Baines <mail@cbaines.net>2020-01-25 22:22:39 +0000
commitfa412cdb5985ec4199f89510d8d8cde9b7664e2d (patch)
treed4650e78333873df4837840a11560e60ab83928c /src/schema.sql
parent9eb96d1b197d674d34daf4de8c75fa9ee337f583 (diff)
downloadcuirass-improve-handling-of-rowids.tar
cuirass-improve-handling-of-rowids.tar.gz
Alter the Builds table to have an id fieldimprove-handling-of-rowids
The internal rowid's are used for builds as you can request builds by using the rowid in the URL. The motivation here is to enable running VACUUM operations in SQLite, without risking the rowid's for Builds changing. It would be bad if they change, as they're used in the URL's for builds. * src/schema.sql (Builds): Add id column. * src/curiass/dataabse.scm (db-add-build): Change PRIMARYKEY constraint to UNIQUE constraint. * src/sql/upgrade-6.sql: New file. * Makefile.am (dist_sql_DATA): Add it.
Diffstat (limited to 'src/schema.sql')
-rw-r--r--src/schema.sql3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/schema.sql b/src/schema.sql
index cd67530..1104551 100644
--- a/src/schema.sql
+++ b/src/schema.sql
@@ -51,7 +51,8 @@ CREATE TABLE Outputs (
);
CREATE TABLE Builds (
- derivation TEXT NOT NULL PRIMARY KEY,
+ id INTEGER NOT NULL PRIMARY KEY,
+ derivation TEXT NOT NULL UNIQUE,
evaluation INTEGER NOT NULL,
job_name TEXT NOT NULL,
system TEXT NOT NULL,