aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-16 18:31:46 +0100
committerLudovic Courtès <ludo@gnu.org>2018-03-02 13:46:25 +0100
commitf14c933df16ee0faee6bff8004da4e5d3e1caf07 (patch)
tree5f6f3a395aeb4ccb1bd070ad690d57696df3f048 /tests
parente37944d8270cdca5729e3583136c4fe9d487779c (diff)
downloadguix-f14c933df16ee0faee6bff8004da4e5d3e1caf07.tar
guix-f14c933df16ee0faee6bff8004da4e5d3e1caf07.tar.gz
Add (guix glob).
* guix/glob.scm, tests/glob.scm: New files. * Makefile.am (MODULES): Add guix/glob.scm. (SCM_TESTS): Add tests/glob.scm.
Diffstat (limited to 'tests')
-rw-r--r--tests/glob.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/tests/glob.scm b/tests/glob.scm
new file mode 100644
index 0000000000..033eeb10fe
--- /dev/null
+++ b/tests/glob.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-glob)
+ #:use-module (guix glob)
+ #:use-module (srfi srfi-64))
+
+
+(test-begin "glob")
+
+(test-equal "compile-glob-pattern, no wildcards"
+ "foo"
+ (compile-glob-pattern "foo"))
+
+(test-equal "compile-glob-pattern, Kleene star"
+ '("foo" * "bar")
+ (compile-glob-pattern "foo*bar"))
+
+(test-equal "compile-glob-pattern, question mark"
+ '(? "foo" *)
+ (compile-glob-pattern "?foo*"))
+
+(test-assert "literal match"
+ (let ((pattern (compile-glob-pattern "foo")))
+ (and (glob-match? pattern "foo")
+ (not (glob-match? pattern "foobar"))
+ (not (glob-match? pattern "barfoo")))))
+
+(test-assert "trailing star"
+ (let ((pattern (compile-glob-pattern "foo*")))
+ (and (glob-match? pattern "foo")
+ (glob-match? pattern "foobar")
+ (not (glob-match? pattern "xfoo")))))
+
+(test-assert "question marks"
+ (let ((pattern (compile-glob-pattern "foo??bar")))
+ (and (glob-match? pattern "fooxxbar")
+ (glob-match? pattern "fooZZbar")
+ (not (glob-match? pattern "foobar"))
+ (not (glob-match? pattern "fooxxxbar"))
+ (not (glob-match? pattern "fooxxbarzz")))))
+
+(test-end "glob")