aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-03 23:41:35 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-28 22:28:47 -0400
commit0ea62e84a787fe94cfeadf67ef27ea995a382b84 (patch)
tree26b17f29b5e0ed2f1a5d5335b6469d6c428c8dd0 /tests
parent42fee6d0f176aea5d208e3e6d8b5270abcf4173c (diff)
downloadguix-0ea62e84a787fe94cfeadf67ef27ea995a382b84.tar
guix-0ea62e84a787fe94cfeadf67ef27ea995a382b84.tar.gz
services: Add lightdm-service-type.
* gnu/services/lightdm.scm: New service. * tests/services/lightdm.scm: Test it. * doc/guix.texi (X Window): Document it. * gnu/local.mk (GNU_SYSTEM_MODULES): Register it. Co-authored-by: L p R n d n <guix@lprndn.info> Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'tests')
-rw-r--r--tests/services/lightdm.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/tests/services/lightdm.scm b/tests/services/lightdm.scm
new file mode 100644
index 0000000000..283df2befc
--- /dev/null
+++ b/tests/services/lightdm.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (tests services lightdm)
+ #:use-module (guix diagnostics)
+ #:use-module (gnu services lightdm)
+ #:use-module (srfi srfi-64))
+
+;;; Tests for the (gnu services lightdm) module.
+
+;;; Access some internals for whitebox testing.
+(define validate-lightdm-configuration (@@ (gnu services lightdm)
+ validate-lightdm-configuration))
+
+(test-begin "lightdm-service")
+
+(test-equal "error on missing greeter"
+ 'ok
+ (catch 'quit
+ (lambda ()
+ (validate-lightdm-configuration (lightdm-configuration (greeters '()))))
+ (lambda _
+ 'ok)))
+
+(test-equal "error when a greeter has multiple configurations"
+ 'ok
+ (catch 'quit
+ (lambda ()
+ (lightdm-configuration
+ (greeters (list (lightdm-gtk-greeter-configuration
+ (theme-name "boring"))
+ (lightdm-gtk-greeter-configuration
+ (theme-name "blue"))))))
+ (lambda _
+ 'ok)))
+
+(test-end "lightdm-service")