aboutsummaryrefslogtreecommitdiff
path: root/tests/workers.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-04-17 22:04:31 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-18 23:17:17 +0200
commit1563d6c79f759cb9a6cc5561463653f0f184cb36 (patch)
tree25d63a946bdb969252371000de7044cc4938b3d0 /tests/workers.scm
parent54412ebfeb51de88eecde28ac69ace46b2d9e420 (diff)
downloadguix-1563d6c79f759cb9a6cc5561463653f0f184cb36.tar
guix-1563d6c79f759cb9a6cc5561463653f0f184cb36.tar.gz
Add (guix workers).
* guix/workers.scm, tests/workers.scm: New files. * Makefile.am (MODULES, SCM_TESTS): Add them. * .dir-locals.el: Add rule for 'eventually'.
Diffstat (limited to 'tests/workers.scm')
-rw-r--r--tests/workers.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/tests/workers.scm b/tests/workers.scm
new file mode 100644
index 0000000000..44b882f691
--- /dev/null
+++ b/tests/workers.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-workers)
+ #:use-module (guix workers)
+ #:use-module (ice-9 threads)
+ #:use-module (srfi srfi-64))
+
+(test-begin "workers")
+
+(test-equal "enqueue"
+ 4242
+ (let* ((pool (make-pool))
+ (result 0)
+ (1+! (let ((lock (make-mutex)))
+ (lambda ()
+ (with-mutex lock
+ (set! result (+ result 1)))))))
+ (let loop ((i 4242))
+ (unless (zero? i)
+ (pool-enqueue! pool 1+!)
+ (loop (- i 1))))
+ (let poll ()
+ (unless (pool-idle? pool)
+ (pk 'busy result)
+ (sleep 1)
+ (poll)))
+ result))
+
+(test-end)