aboutsummaryrefslogtreecommitdiff
path: root/po
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-03 00:54:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-03 09:29:45 -0400
commitf13049f3a856d842fee1abb50e61481b891f2020 (patch)
tree8a2e13a8a1e55ba26f71f8895dd77c0b174d19f1 /po
parentf995f710e823a26660235928cdfa00a4024cf43a (diff)
downloadguix-f13049f3a856d842fee1abb50e61481b891f2020.tar
guix-f13049f3a856d842fee1abb50e61481b891f2020.tar.gz
nls: Remove the doc-po-update target.
As discussed with Julien Lepiller on IRC, updating the PO files is not useful. This change removes the target and associated rules that allowed updating them. This has the benefit of not having the PO files updated automatically when generating the .pot files, which was causing spurious changes under the po sub-directory. * po/doc/local.mk (make-update-po-files-rule): Remove function and its uses. (doc-po-update): Remove target.
Diffstat (limited to 'po')
-rw-r--r--po/doc/local.mk21
1 files changed, 1 insertions, 20 deletions
diff --git a/po/doc/local.mk b/po/doc/local.mk
index 4458774efe..4c47491c32 100644
--- a/po/doc/local.mk
+++ b/po/doc/local.mk
@@ -47,20 +47,6 @@ POT_OPTIONS = \
--copyright-holder "the authors of Guix (msgids)" \
--msgid-bugs-address "bug-guix@gnu.org"
-# make-update-po-files-rule PO_FILES POT_FILE_INPUT
-define make-update-po-files-rule
-$(1): $(2)
- @if ! [ -f "$$@" ]; then \
- echo "File $$po_file does not exist. If you are a translator, \
-you can create it with 'msginit'." 1>&2; \
- exit 1; \
- fi && \
- lang=$$$$(echo $$@ | $(SED) -E 's|.*\.([^.]*)\.po$$$$|\1|') && \
- echo $(MSGMERGE_UPDATE) $(MSGMERGE_OPTIONS) \
- --lang=$$$${lang} "$$@" "$$<" && \
- $(MSGMERGE_UPDATE) $(MSGMERGE_OPTIONS) --lang=$$$${lang} "$$@" "$$<"
-endef
-
%D%/%.pot: $(srcdir)/doc/%.texi
$(AM_V_PO4A)$(PO4A_UPDATEPO) -M UTF-8 -f texinfo -m "$<" \
-p "$@" $(POT_OPTIONS) && \
@@ -69,10 +55,5 @@ endef
%D%/guix-manual.pot: %D%/guix.pot %D%/contributing.pot
msgcat $^ > $@
-$(eval $(call make-update-po-files-rule,$(DOC_PO_FILES),%D%/guix-manual.pot))
-$(eval $(call make-update-po-files-rule,\
- $(DOC_COOKBOOK_PO_FILES),%D%/guix-cookbook.pot))
-
doc-pot-update: %D%/guix-manual.pot %D%/guix-cookbook.pot
-doc-po-update: $(DOC_PO_FILES) $(DOC_COOKBOOK_PO_FILES)
-.PHONY: doc-pot-update doc-po-update
+.PHONY: doc-pot-update