aboutsummaryrefslogtreecommitdiff
path: root/po
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-05-02 22:12:16 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-05-03 09:29:44 -0400
commita23789bbbdd23b1130f0f2521ee8d68872b7fc2c (patch)
treef6fbe27e3fa836112ca2c76a852540a4ce7205fb /po
parent283d4960a47e51bfab5466ca857cf3eddeacbe2e (diff)
downloadguix-a23789bbbdd23b1130f0f2521ee8d68872b7fc2c.tar
guix-a23789bbbdd23b1130f0f2521ee8d68872b7fc2c.tar.gz
nls: Do not update po files on first make invocation.
We need to update the minimal gettext version to take advantage of new features. Before this patch, the first make invocation would modify po/guix and po/packages po files, and we advised to run `git checkout po` to clean the changes. * configure.ac (AM_GNU_GETTEXT_VERSION): Update to 0.19.1. * po/guix/Makevars: Set PO_DEPENDS_ON_POT to no. * po/packages/Makevars: Set PO_DEPENDS_ON_POT to no. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'po')
-rw-r--r--po/guix/Makevars5
-rw-r--r--po/packages/Makevars5
2 files changed, 10 insertions, 0 deletions
diff --git a/po/guix/Makevars b/po/guix/Makevars
index 363bf98dfd..88a4e8c7bc 100644
--- a/po/guix/Makevars
+++ b/po/guix/Makevars
@@ -26,3 +26,8 @@ EXTRA_LOCALE_CATEGORIES =
# "make distcheck -j4".
# See <https://lists.gnu.org/archive/html/bug-gettext/2014-08/msg00005.html>.
DIST_DEPENDS_ON_UPDATE_PO = no
+
+# Ignore the timestamp of the .pot file, as .po files are updated by
+# `make download-po` only. This ensures po files are not modified on the
+# first `make` invocation.
+PO_DEPENDS_ON_POT = no
diff --git a/po/packages/Makevars b/po/packages/Makevars
index 39366fbee9..4cdb98d8fe 100644
--- a/po/packages/Makevars
+++ b/po/packages/Makevars
@@ -22,3 +22,8 @@ EXTRA_LOCALE_CATEGORIES =
# "make distcheck -j4".
# See <https://lists.gnu.org/archive/html/bug-gettext/2014-08/msg00005.html>.
DIST_DEPENDS_ON_UPDATE_PO = no
+
+# Ignore the timestamp of the .pot file, as .po files are updated by
+# `make download-po` only. This ensures po files are not modified on the
+# first `make` invocation.
+PO_DEPENDS_ON_POT = no