aboutsummaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-07 23:12:27 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-08 00:47:35 +0200
commitb5eb901ab508e13a10d8c11fe0c9d0d06dddce96 (patch)
treee8555d5c52e27edf3dfa097c402964ccb24ffd0d /guix
parentd15c7974a2346ec0d379eba3fd60ef59012d9a80 (diff)
downloadguix-b5eb901ab508e13a10d8c11fe0c9d0d06dddce96.tar
guix-b5eb901ab508e13a10d8c11fe0c9d0d06dddce96.tar.gz
Remove (guix json) and require Guile-JSON 4.3.0+.
This is a followup to 4071879c86d059ee087c8986915ea72b8c742b72. * guix/json.scm: Remove. * Makefile.am (MODULES): Adjust accordingly. * m4/guix.m4 (GUIX_CHECK_GUILE_JSON): Check for 'define-json-mapping'. * doc/guix.texi (Requirements): Require Guile-JSON 4.3.0+. * guix/ci.scm, guix/cve.scm, guix/import/cpan.scm, guix/import/crate.scm, guix/swh.scm: Remove (guix json) import. * guix/import/gem.scm, guix/import/pypi.scm: Likewise, and import (json). * guix/self.scm (specification->package): Switch to GUILE-JSON-4. * guix/git-download.scm (git-fetch): Likewise.
Diffstat (limited to 'guix')
-rw-r--r--guix/ci.scm1
-rw-r--r--guix/cve.scm1
-rw-r--r--guix/git-download.scm4
-rw-r--r--guix/import/cpan.scm1
-rw-r--r--guix/import/crate.scm1
-rw-r--r--guix/import/gem.scm2
-rw-r--r--guix/import/pypi.scm2
-rw-r--r--guix/json.scm83
-rw-r--r--guix/self.scm2
-rw-r--r--guix/swh.scm1
10 files changed, 5 insertions, 93 deletions
diff --git a/guix/ci.scm b/guix/ci.scm
index 02eb90e6c3..7a03befc7c 100644
--- a/guix/ci.scm
+++ b/guix/ci.scm
@@ -19,7 +19,6 @@
(define-module (guix ci)
#:use-module (guix http-client)
- #:use-module (guix json)
#:use-module (json)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match)
diff --git a/guix/cve.scm b/guix/cve.scm
index ae9cca2341..57b8459d01 100644
--- a/guix/cve.scm
+++ b/guix/cve.scm
@@ -19,7 +19,6 @@
(define-module (guix cve)
#:use-module (guix utils)
#:use-module (guix http-client)
- #:use-module (guix json)
#:use-module (guix i18n)
#:use-module ((guix diagnostics) #:select (formatted-message))
#:use-module (json)
diff --git a/guix/git-download.scm b/guix/git-download.scm
index 90634a8c4c..8e575e3b5f 100644
--- a/guix/git-download.scm
+++ b/guix/git-download.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
@@ -85,7 +85,7 @@ HASH-ALGO (a symbol). Use NAME as the file name, or a generic name if #f."
'tar)))))
(define guile-json
- (module-ref (resolve-interface '(gnu packages guile)) 'guile-json-3))
+ (module-ref (resolve-interface '(gnu packages guile)) 'guile-json-4))
(define guile-zlib
(module-ref (resolve-interface '(gnu packages guile)) 'guile-zlib))
diff --git a/guix/import/cpan.scm b/guix/import/cpan.scm
index 085467b871..fd940415a2 100644
--- a/guix/import/cpan.scm
+++ b/guix/import/cpan.scm
@@ -28,7 +28,6 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
#:use-module (json)
- #:use-module (guix json)
#:use-module (gcrypt hash)
#:use-module (guix store)
#:use-module (guix utils)
diff --git a/guix/import/crate.scm b/guix/import/crate.scm
index 796a7641e9..f87c89163c 100644
--- a/guix/import/crate.scm
+++ b/guix/import/crate.scm
@@ -24,7 +24,6 @@
#:use-module ((guix download) #:prefix download:)
#:use-module (gcrypt hash)
#:use-module (guix http-client)
- #:use-module (guix json)
#:use-module (guix import json)
#:use-module (guix import utils)
#:use-module ((guix licenses) #:prefix license:)
diff --git a/guix/import/gem.scm b/guix/import/gem.scm
index a2d99ddbca..3fe240f36a 100644
--- a/guix/import/gem.scm
+++ b/guix/import/gem.scm
@@ -22,7 +22,7 @@
(define-module (guix import gem)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1)
- #:use-module (guix json)
+ #:use-module (json)
#:use-module ((guix download) #:prefix download:)
#:use-module (guix import utils)
#:use-module (guix import json)
diff --git a/guix/import/pypi.scm b/guix/import/pypi.scm
index a4a2489688..15116e349d 100644
--- a/guix/import/pypi.scm
+++ b/guix/import/pypi.scm
@@ -46,7 +46,7 @@
#:use-module (guix import utils)
#:use-module ((guix download) #:prefix download:)
#:use-module (guix import json)
- #:use-module (guix json)
+ #:use-module (json)
#:use-module (guix packages)
#:use-module (guix upstream)
#:use-module ((guix licenses) #:prefix license:)
diff --git a/guix/json.scm b/guix/json.scm
deleted file mode 100644
index 3e3a28b749..0000000000
--- a/guix/json.scm
+++ /dev/null
@@ -1,83 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (guix json)
- #:use-module (json)
- #:use-module (srfi srfi-9))
-
-;;; Commentary:
-;;;
-;;; Helpers to map JSON objects to SRFI-9 records. Taken from (guix swh).
-;;; This module is superseded by 'define-json-mapping' as found since version
-;;; 4.2.0 of Guile-JSON and will be removed once migration is complete.
-;;;
-;;; Code:
-
-(define-syntax define-as-needed
- (lambda (s)
- "Define the given syntax rule unless (json) already provides it."
- (syntax-case s ()
- ((_ (macro args ...) body ...)
- (if (module-defined? (resolve-interface '(json))
- (syntax->datum #'macro))
- #'(eval-when (expand load eval)
- ;; Re-export MACRO from (json).
- (module-re-export! (current-module) '(macro)))
- #'(begin
- ;; Using Guile-JSON < 4.2.0, so provide our own MACRO.
- (define-syntax-rule (macro args ...)
- body ...)
- (eval-when (expand load eval)
- (module-export! (current-module) '(macro)))))))))
-
-(define-syntax-rule (define-json-reader json->record ctor spec ...)
- "Define JSON->RECORD as a procedure that converts a JSON representation,
-read from a port, string, or hash table, into a record created by CTOR and
-following SPEC, a series of field specifications."
- (define (json->record input)
- (let ((table (cond ((port? input)
- (json->scm input))
- ((string? input)
- (json-string->scm input))
- ((or (null? input) (pair? input))
- input))))
- (let-syntax ((extract-field (syntax-rules ()
- ((_ table (field key json->value))
- (json->value (assoc-ref table key)))
- ((_ table (field key))
- (assoc-ref table key))
- ((_ table (field))
- (assoc-ref table
- (symbol->string 'field))))))
- (ctor (extract-field table spec) ...)))))
-
-;; For some reason we cannot just have colliding definitions of
-;; 'define-json-mapping' (that leads to a build failure in users of this
-;; module), hence the use of 'define-as-needed'.
-(define-as-needed (define-json-mapping rtd ctor pred json->record
- (field getter spec ...) ...)
- "Define RTD as a record type with the given FIELDs and GETTERs, à la SRFI-9,
-and define JSON->RECORD as a conversion from JSON to a record of this type."
- (begin
- (define-record-type rtd
- (ctor field ...)
- pred
- (field getter) ...)
-
- (define-json-reader json->record ctor
- (field spec ...) ...)))
diff --git a/guix/self.scm b/guix/self.scm
index 6a1640acdf..02ef982c7c 100644
--- a/guix/self.scm
+++ b/guix/self.scm
@@ -49,7 +49,7 @@
(module-ref (resolve-interface module) variable))))
(match-lambda
("guile" (ref '(gnu packages guile) 'guile-3.0/libgc-7))
- ("guile-json" (ref '(gnu packages guile) 'guile-json-3))
+ ("guile-json" (ref '(gnu packages guile) 'guile-json-4))
("guile-ssh" (ref '(gnu packages ssh) 'guile-ssh))
("guile-git" (ref '(gnu packages guile) 'guile-git))
("guile-sqlite3" (ref '(gnu packages guile) 'guile-sqlite3))
diff --git a/guix/swh.scm b/guix/swh.scm
index a343ccfdd7..0b765cc743 100644
--- a/guix/swh.scm
+++ b/guix/swh.scm
@@ -22,7 +22,6 @@
#:use-module (guix build utils)
#:use-module ((guix build syscalls) #:select (mkdtemp!))
#:use-module (web uri)
- #:use-module (guix json)
#:use-module (web client)
#:use-module (web response)
#:use-module (json)