aboutsummaryrefslogtreecommitdiff
path: root/guix/pk-crypto.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-26 21:38:49 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-26 21:58:12 +0100
commit4862bc4a1a20d2abf50b39713cd12985f38adf7c (patch)
treecb22dccbe6eaf3280c0f1e7cbffc5e0bc7a4f63c /guix/pk-crypto.scm
parent72c5ad8bae2272042b758c94c509dc0ff59a9488 (diff)
downloadguix-4862bc4a1a20d2abf50b39713cd12985f38adf7c.tar
guix-4862bc4a1a20d2abf50b39713cd12985f38adf7c.tar.gz
Add (guix gcrypt).
* guix/gcrypt.scm: New file. * Makefile.am (MODULES): Add it. * guix/pk-crypto.scm: Use it. (libgcrypt-func, gcrypt-version): Remove.
Diffstat (limited to 'guix/pk-crypto.scm')
-rw-r--r--guix/pk-crypto.scm26
1 files changed, 5 insertions, 21 deletions
diff --git a/guix/pk-crypto.scm b/guix/pk-crypto.scm
index e5d4dc9ecc..7306b66922 100644
--- a/guix/pk-crypto.scm
+++ b/guix/pk-crypto.scm
@@ -17,15 +17,15 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (guix pk-crypto)
- #:use-module (guix config)
#:use-module ((guix utils)
#:select (bytevector->base16-string
base16-string->bytevector))
+ #:use-module (guix gcrypt)
+
#:use-module (system foreign)
#:use-module (rnrs bytevectors)
#:use-module (ice-9 match)
- #:export (gcrypt-version
- canonical-sexp?
+ #:export (canonical-sexp?
error-source
error-string
string->canonical-sexp
@@ -46,7 +46,8 @@
generate-key
find-sexp-token
canonical-sexp->sexp
- sexp->canonical-sexp))
+ sexp->canonical-sexp)
+ #:re-export (gcrypt-version))
;;; Commentary:
@@ -81,23 +82,6 @@
(number->string (pointer-address (canonical-sexp->pointer obj))
16))))
-(define libgcrypt-func
- (let ((lib (dynamic-link %libgcrypt)))
- (lambda (func)
- "Return a pointer to symbol FUNC in libgcrypt."
- (dynamic-func func lib))))
-
-(define gcrypt-version
- ;; According to the manual, this function must be called before any other,
- ;; and it's not clear whether it can be called more than once. So call it
- ;; right here from the top level.
- (let* ((ptr (libgcrypt-func "gcry_check_version"))
- (proc (pointer->procedure '* ptr '(*)))
- (version (pointer->string (proc %null-pointer))))
- (lambda ()
- "Return the version number of libgcrypt as a string."
- version)))
-
(define finalize-canonical-sexp!
(libgcrypt-func "gcry_sexp_release"))