aboutsummaryrefslogtreecommitdiff
path: root/guix/build
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-08-31 17:03:02 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-11-30 18:19:31 +0530
commit3d0aa7f70bed99fd04c7b2c2a8d7a4486e0a1364 (patch)
tree7847d9571b8f54f34053ea61380057d6c3068578 /guix/build
parentbf630276a1c853ec7484f5422d0595a11f51a58b (diff)
downloadguix-3d0aa7f70bed99fd04c7b2c2a8d7a4486e0a1364.tar
guix-3d0aa7f70bed99fd04c7b2c2a8d7a4486e0a1364.tar.gz
build-system: Add scons-build-system.
* guix/build-system/scons.scm: New file. * guix/build/scons-build-system.scm: New file. * Makefile.am (MODULES): Register them. * doc/guix.texi (Build Systems): Add scons-build-system.
Diffstat (limited to 'guix/build')
-rw-r--r--guix/build/scons-build-system.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/guix/build/scons-build-system.scm b/guix/build/scons-build-system.scm
new file mode 100644
index 0000000000..a8760968d8
--- /dev/null
+++ b/guix/build/scons-build-system.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build scons-build-system)
+ #:use-module ((guix build gnu-build-system) #:prefix gnu:)
+ #:use-module (guix build utils)
+ #:export (%standard-phases
+ scons-build))
+
+;; Commentary:
+;;
+;; Builder-side code of the SCons build system.
+;;
+;; Code:
+
+(define* (build #:key outputs (scons-flags '()) (parallel-build? #t) #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p out)
+ (zero? (apply system* "scons"
+ (append (if parallel-build?
+ (list "-j" (number->string
+ (parallel-job-count)))
+ (list))
+ scons-flags)))))
+
+(define* (check #:key tests? test-target (scons-flags '()) #:allow-other-keys)
+ "Run the test suite of a given SCons application."
+ (cond (tests?
+ (zero? (apply system* "scons" test-target scons-flags)))
+ (else
+ (format #t "test suite not run~%")
+ #t)))
+
+(define* (install #:key outputs (scons-flags '()) #:allow-other-keys)
+ "Install a given SCons application."
+ (zero? (apply system* "scons" "install" scons-flags)))
+
+(define %standard-phases
+ (modify-phases gnu:%standard-phases
+ (delete 'configure)
+ (replace 'build build)
+ (replace 'check check)
+ (replace 'install install)))
+
+(define* (scons-build #:key inputs (phases %standard-phases)
+ #:allow-other-keys #:rest args)
+ "Build a given SCons application, applying all of PHASES in order."
+ (apply gnu:gnu-build #:inputs inputs #:phases phases args))
+
+;;; scons-build-system.scm ends here