aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2017-08-24 14:27:29 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-09-01 08:34:32 +0200
commite464b4550e42d913655bd5939d3e370982ee294b (patch)
tree89aec11d9b138f5d870f3b919a556aed887db1ea /gnu
parentfd0378a1475900bdbd1da43066811677ba41f3ea (diff)
downloadguix-e464b4550e42d913655bd5939d3e370982ee294b.tar
guix-e464b4550e42d913655bd5939d3e370982ee294b.tar.gz
gnu: hdf4: Avoid unneeded store references to compilers.
* gnu/packages/maths.scm (hdf4) [arguments]: Add phase 'patch-settings to truncate hashes of compiler store items.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 47e7ba35db..a8c81a79ca 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -605,7 +605,18 @@ computations.")
(("@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = \
-R\\$\\(abs_top_builddir\\)/mfhdf/libsrc/\\.libs \
-R\\$\\(abs_top_builddir\\)/hdf/src/\\.libs \\$\\(XDR_ADD\\)") ""))
- #t)))))
+ #t))
+ (add-after 'configure 'patch-settings
+ (lambda _
+ ;; libhdf4.settings contains the full path of the
+ ;; compilers used, and its contents are included in
+ ;; .so-files. We truncate the hashes to avoid
+ ;; unnecessary store references to those compilers:
+ (substitute* "libhdf4.settings"
+ (("(/gnu/store/)([a-Z0-9]*)" all prefix hash)
+ (string-append prefix (string-take hash 10) "...")))
+ #t))
+ )))
(home-page "https://www.hdfgroup.org/products/hdf4/")
(synopsis
"Library and multi-object file format for storing and managing data")