aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-07-14 18:54:03 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-07-14 18:54:10 +1000
commitd6e63cf31cc113e310cd0e5dda9ac4f73a5caeae (patch)
treea51bf98b7f95363716893f7ab10de589e8e9e27e /gnu
parent78a81e37cddc31af93002b9853ebd79e9828fa8a (diff)
downloadguix-d6e63cf31cc113e310cd0e5dda9ac4f73a5caeae.tar
guix-d6e63cf31cc113e310cd0e5dda9ac4f73a5caeae.tar.gz
gnu: bowtie: Update to 2.3.2.
* gnu/packages/bioinformatics.scm (bowtie): Update to 2.3.2. [inputs]: Add zlib.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 82cd1e420d..a9f6259897 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1195,7 +1195,7 @@ errors at the end of reads.")
(define-public bowtie
(package
(name "bowtie")
- (version "2.2.9")
+ (version "2.3.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/BenLangmead/bowtie2/archive/v"
@@ -1203,7 +1203,7 @@ errors at the end of reads.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1vp5db8i7is57iwjybcdg18f5ivyzlj5g1ix1nlvxainzivhz55g"))
+ "0hwa5r9qbglppb7sz5z79rlmmddr3n51n468jb3wh8rwjgn3yr90"))
(modules '((guix build utils)))
(snippet
'(substitute* "Makefile"
@@ -1211,12 +1211,14 @@ errors at the end of reads.")
(("-DBUILD_HOST=.*") "-DBUILD_HOST=\"\\\"guix\\\"\"")
(("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))))
(build-system gnu-build-system)
- (inputs `(("perl" ,perl)
- ("perl-clone" ,perl-clone)
- ("perl-test-deep" ,perl-test-deep)
- ("perl-test-simple" ,perl-test-simple)
- ("python" ,python-2)
- ("tbb" ,tbb)))
+ (inputs
+ `(("perl" ,perl)
+ ("perl-clone" ,perl-clone)
+ ("perl-test-deep" ,perl-test-deep)
+ ("perl-test-simple" ,perl-test-simple)
+ ("python" ,python-2)
+ ("tbb" ,tbb)
+ ("zlib" ,zlib)))
(arguments
'(#:make-flags
(list "allall"