aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 15:20:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 16:18:41 +0100
commitc5f033e0f6f6e1df2ddc76a8bf799be3e062e5eb (patch)
tree1922c1d2765e8a431ff77dfe85108f9f1c984e50 /gnu
parentfe5b8893653c112edc60afee4de3ef6f584f8116 (diff)
downloadguix-c5f033e0f6f6e1df2ddc76a8bf799be3e062e5eb.tar
guix-c5f033e0f6f6e1df2ddc76a8bf799be3e062e5eb.tar.gz
gnu: Add r-squarem.
* gnu/packages/cran.scm (r-squarem): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8c69805765..4d4d3edf3c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -989,6 +989,29 @@ testing framework of Wald are generic and can therefore also be used in other
contexts.")
(license license:gpl2+)))
+(define-public r-squarem
+ (package
+ (name "r-squarem")
+ (version "2017.10-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "SQUAREM" version))
+ (sha256
+ (base32
+ "10xj26x7qjyvzndnbjl5krr9wabnb9cbrnp3m7xg673g8ddr12cv"))))
+ (properties `((upstream-name . "SQUAREM")))
+ (build-system r-build-system)
+ (home-page "http://www.jhsph.edu/agingandhealth/People/Faculty_personal_pages/Varadhan.html")
+ (synopsis "Squared Extrapolation Methods for Accelerating EM-Like Monotone Algorithms")
+ (description
+ "This package provides algorithms for accelerating the convergence of
+slow, monotone sequences from smooth, contraction mapping such as the EM
+algorithm. It can be used to accelerate any smooth, linearly convergent
+acceleration scheme. A tutorial style introduction to this package is
+available in a vignette.")
+ (license license:gpl2+)))
+
(define-public r-lava
(package
(name "r-lava")