aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-17 00:52:15 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-18 00:48:16 +0100
commitbfb06e580e3ff497e057e2d85f95b2fe9f7f908b (patch)
treec7983ebb237819251fdd36ed554a328fc8b2ad29 /gnu
parentff9d1a2f0c9cc82ae4c73d8660a87829bae9bf30 (diff)
downloadguix-bfb06e580e3ff497e057e2d85f95b2fe9f7f908b.tar
guix-bfb06e580e3ff497e057e2d85f95b2fe9f7f908b.tar.gz
gnu: shepherd: Add dependency on guile-readline.
* gnu/packages/admin.scm (shepherd)[inputs]: Add GUILE-READLINE.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index ae89bd07a1..6121402048 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2015, 2016, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
@@ -178,7 +178,11 @@ and provides a \"top-like\" mode (monitoring).")
("guile" ,guile-2.2)))
(inputs
;; ... and this is the one that appears in shebangs when cross-compiling.
- `(("guile" ,guile-2.2)))
+ `(("guile" ,guile-2.2)
+
+ ;; The 'shepherd' command uses Readline when used interactively. It's
+ ;; an unusual use case though, so we don't propagate it.
+ ("guile-readline" ,guile-readline)))
(synopsis "System service manager")
(description
"The GNU Shepherd is a daemon-managing daemon, meaning that it supervises