aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-24 18:37:02 -0400
committerLeo Famulari <leo@famulari.name>2016-10-26 18:44:16 -0400
commita19da40630138acea7169491a6926e00cf7d301b (patch)
tree9e40a7dac26b061d511b76376a76bf93c66a1996 /gnu
parentc4a667bfa5ebdef494e0b1703f9bc5882873d954 (diff)
downloadguix-a19da40630138acea7169491a6926e00cf7d301b.tar
guix-a19da40630138acea7169491a6926e00cf7d301b.tar.gz
gnu: perl-www-curl: Fix build failure.
* gnu/packages/patches/perl-www-curl-remove-symbol.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/web.scm (perl-www-curl)[source]: Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/perl-www-curl-remove-symbol.patch39
-rw-r--r--gnu/packages/web.scm1
3 files changed, 41 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f754801613..446c5e1172 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -751,6 +751,7 @@ dist_patch_DATA = \
%D%/packages/patches/perl-no-sys-dirs.patch \
%D%/packages/patches/perl-module-pluggable-search.patch \
%D%/packages/patches/perl-reproducible-build-date.patch \
+ %D%/packages/patches/perl-www-curl-remove-symbol.patch \
%D%/packages/patches/pidgin-add-search-path.patch \
%D%/packages/patches/pinball-const-fix.patch \
%D%/packages/patches/pinball-cstddef.patch \
diff --git a/gnu/packages/patches/perl-www-curl-remove-symbol.patch b/gnu/packages/patches/perl-www-curl-remove-symbol.patch
new file mode 100644
index 0000000000..ae3486708b
--- /dev/null
+++ b/gnu/packages/patches/perl-www-curl-remove-symbol.patch
@@ -0,0 +1,39 @@
+Fix build failure caused by erroneous use of an undeclared symbol.
+
+Patch copied from upstream bug report:
+https://rt.cpan.org/Public/Bug/Display.html?id=117793
+
+From 0be0223422e6e5f4091c6e4e058d213623eed105 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
+Date: Mon, 12 Sep 2016 14:40:44 +0200
+Subject: [PATCH] Skip preprocessor symbol only CURL_STRICTER
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+CURL_STRICTER leaked into curl-constants.c when building against
+curl-7.50.2. This is a preprocessor only macro without a value.
+
+CPAN RT#117793
+
+Signed-off-by: Petr Písař <ppisar@redhat.com>
+---
+ Makefile.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index f9170bb..ad2bd3d 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -127,7 +127,7 @@ if (!defined($curl_h)) {
+ close H;
+
+ for my $e (sort @syms) {
+- if($e =~ /(OBSOLETE|^CURL_EXTERN|_LAST\z|_LASTENTRY\z)/) {
++ if($e =~ /(OBSOLETE|^CURL_EXTERN|^CURL_STRICTER\z|_LAST\z|_LASTENTRY\z)/) {
+ next;
+ }
+ my ($group) = $e =~ m/^([^_]+_)/;
+--
+2.7.4
+
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index cabf1e6b49..60f1f736cd 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3053,6 +3053,7 @@ RFC 6570.")
(uri (string-append
"mirror://cpan/authors/id/S/SZ/SZBALINT/WWW-Curl-"
version".tar.gz"))
+ (patches (search-patches "perl-www-curl-remove-symbol.patch"))
(sha256
(base32
"1fmp9aib1kaps9vhs4dwxn7b15kgnlz9f714bxvqsd1j1q8spzsj"))))