aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2016-03-26 13:56:14 +0100
committerLudovic Courtès <ludo@gnu.org>2016-04-01 00:05:42 +0200
commit2cdeecbe4da32b4ec8c23c338f11cd16d6eededa (patch)
tree6c9a8eb8b140fdb5ab1fd46516338f83f7415c0d /gnu
parentec0730cb6705d674cc6c52819c81ffb32f693ab8 (diff)
downloadguix-2cdeecbe4da32b4ec8c23c338f11cd16d6eededa.tar
guix-2cdeecbe4da32b4ec8c23c338f11cd16d6eededa.tar.gz
gnu: move miscfiles into gnu-doc.scm
* gnu/packages/miscfiles.scm: Remove file. * gnu-sytem.am: Remove it. * gnu/packages/gnu-doc.scm (miscfiles): Move here. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnu-doc.scm27
-rw-r--r--gnu/packages/miscfiles.scm47
2 files changed, 27 insertions, 47 deletions
diff --git a/gnu/packages/gnu-doc.scm b/gnu/packages/gnu-doc.scm
index 572647d024..3daa54ff12 100644
--- a/gnu/packages/gnu-doc.scm
+++ b/gnu/packages/gnu-doc.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -21,11 +22,37 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages texinfo)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (guix cvs-download)
+ #:use-module (guix download)
#:use-module (guix licenses)
#:use-module (guix packages))
+(define-public miscfiles
+ (package
+ (name "miscfiles")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/" name "/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "005588vfrwx8ghsdv9p7zczj9lbc9a3r4m5aphcaqv8gif4siaka"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.gnu.org/software/miscfiles/")
+ (synopsis
+ "Data files for airport codes, zip codes, a dictionary, and more")
+ (description
+ "GNU Miscfiles is a collection of common data files. They include, for
+example, country abbreviations, names and capital cities; currency
+abbreviations and names; a Best Current Practices index; a map of the ASCII
+character set; a list of three-letter airport codes; and an English word
+list.")
+ (license gpl2+)))
+
(define-public gnu-standards
(package
(name "gnu-standards")
diff --git a/gnu/packages/miscfiles.scm b/gnu/packages/miscfiles.scm
deleted file mode 100644
index fd0fc7b8e2..0000000000
--- a/gnu/packages/miscfiles.scm
+++ /dev/null
@@ -1,47 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright 2014 John Darrington <jmd@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages miscfiles)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public miscfiles
- (package
- (name "miscfiles")
- (version "1.5")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/" name "/" name "-"
- version ".tar.gz"))
- (sha256
- (base32
- "005588vfrwx8ghsdv9p7zczj9lbc9a3r4m5aphcaqv8gif4siaka"))))
- (build-system gnu-build-system)
- (home-page "https://www.gnu.org/software/miscfiles/")
- (synopsis
- "Data files for airport codes, zip codes, a dictionary, and more")
- (description
- "GNU Miscfiles is a collection of common data files. They include, for
-example, country abbreviations, names and capital cities; currency
-abbreviations and names; a Best Current Practices index; a map of the ASCII
-character set; a list of three-letter airport codes; and an English word
-list.")
- (license gpl2+)))