aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 09:18:23 +0100
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2021-03-15 10:52:55 +0100
commitae807fdb3736f8fbe60caa2ac1fbf2511aab561e (patch)
tree1885203d3197dedc657a2b9cd14fc76e35993df7 /gnu
parentc4e826bbd2dd22bd7005cbb5e32e2a5018e6216d (diff)
downloadguix-ae807fdb3736f8fbe60caa2ac1fbf2511aab561e.tar
guix-ae807fdb3736f8fbe60caa2ac1fbf2511aab561e.tar.gz
gnu: Add r-qdapregex.
* gnu/packages/cran.scm (r-qdapregex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e6b205077b..c41d6d953d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27353,3 +27353,29 @@ predictions either by cell means or by more advanced/powerful mixed effects
models, yielding predictions and confidence intervals that may be easily
visualized at any level of the experiment's design.")
(license license:gpl2+)))
+
+(define-public r-qdapregex
+ (package
+ (name "r-qdapregex")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "qdapRegex" version))
+ (sha256
+ (base32
+ "1xa8q1way3gjadrjh3mv3xr4c6b4h16nd2c6lgl969difplpfz9p"))))
+ (properties `((upstream-name . "qdapRegex")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-stringi" ,r-stringi)))
+ (home-page
+ "https://trinker.github.com/qdapRegex/")
+ (synopsis
+ "Regular Expression Removal, Extraction, and Replacement Tools")
+ (description
+ "This package provides a collection of regular expression tools
+associated with the @code{qdap} package that may be useful outside of the
+context of discourse analysis. Tools include removal/extraction/replacement of
+abbreviations, dates, dollar amounts, email addresses, hash tags, numbers,
+percentages, citations, person tags, phone numbers, times, and zip codes.")
+ (license license:gpl2)))