aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-13 23:53:53 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-14 00:08:30 +0100
commitf833399811555a13756aa64bb0aaaaafab79ee99 (patch)
tree7f8aa98f7aec60c63e7ac0a9e94e01bee05f8867 /gnu
parent94268d502119c2b799cb49069fbbac8322d2dca7 (diff)
downloadguix-f833399811555a13756aa64bb0aaaaafab79ee99.tar
guix-f833399811555a13756aa64bb0aaaaafab79ee99.tar.gz
gnu: Add texlive-fp.
* gnu/packages/tex.scm (texlive-fp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 76ab1bed22..837cb886f9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9206,6 +9206,21 @@ uppercase letters commonly used to represent various number sets.
LaTeX macro support is provided in package @code{psnfss}.")
(license license:gpl3+)))
+(define-public texlive-fp
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-fp"
+ (list "doc/latex/fp/" "tex/latex/fp/" "tex/plain/fp/")
+ (base32 "1q555fx71cf88sn3npzb0j2i10ak920k0qc9ccdygz99vqg10dad")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/fp")
+ (synopsis "Fixed point arithmetic")
+ (description
+ "This package provides an extensive collection of arithmetic operations
+for fixed point real numbers of high precision.")
+ (license license:lppl)))
+
(define-public texlive-fpl
(package
(inherit (simple-texlive-package