aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-03-20 19:03:39 +0100
committerAndreas Enge <andreas@enge.fr>2023-03-20 19:03:39 +0100
commitbfe569e84b539c505e1e432d8ceea91e1481e904 (patch)
tree28c31458050f9dbc134a03c0e188d460bee50c20 /gnu
parentccb62d8feb50e2859d7c41429a9e3d9e0fe30bfe (diff)
parent30f4b3a7e87f6d89d36dad63d8c5a8d065050563 (diff)
downloadguix-bfe569e84b539c505e1e432d8ceea91e1481e904.tar
guix-bfe569e84b539c505e1e432d8ceea91e1481e904.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm141
-rw-r--r--gnu/packages/cran.scm21
-rw-r--r--gnu/packages/java.scm4
3 files changed, 165 insertions, 1 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e54c9ccf2b..d532360f7e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2098,6 +2098,96 @@ impute GReX can be trained with a training dataset where the real total
expression values are known.")
(license license:gpl3)))
+(define-public r-affyilm
+ (package
+ (name "r-affyilm")
+ (version "1.50.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "affyILM" version))
+ (sha256
+ (base32 "0i2hjaqjz06ym5kbw5da1h3cahc630mjwljsji1l2ks0gjcipll0"))))
+ (properties `((upstream-name . "affyILM")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affxparser
+ r-affy
+ r-biobase
+ r-gcrma))
+ (home-page "https://bioconductor.org/packages/affyILM")
+ (synopsis
+ "Linear model of background subtraction and the Langmuir isotherm")
+ (description
+ "The affyILM package is a preprocessing tool which estimates gene
+expression levels for Affymetrix Gene Chips. Input from physical chemistry is
+employed to first background subtract intensities before calculating
+concentrations on behal of the Langmuir model.")
+ (license license:gpl3)))
+
+(define-public r-affylmgui
+ (package
+ (name "r-affylmgui")
+ (version "1.72.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "affylmGUI" version))
+ (sha256
+ (base32 "0jds73pxqf522wcg8qd4b4k1qbhn51av5md1nhgcdnb6is0lzvxi"))))
+ (properties `((upstream-name . "affylmGUI")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affy
+ r-affyio
+ r-affyplm
+ r-annotationdbi
+ r-biocgenerics
+ r-biocmanager
+ r-gcrma
+ r-limma
+ r-r2html
+ r-tkrplot
+ r-xtable))
+ (home-page "https://bioinf.wehi.edu.au/affylmGUI/")
+ (synopsis "GUI for limma package with Affymetrix microarrays")
+ (description
+ "This package provides a @acronym{GUI, Graphical User Interface} for
+analysis of Affymetrix microarray gene expression data using the affy and
+limma packages.")
+ (license license:gpl2+)))
+
+(define-public r-affyplm
+ (package
+ (name "r-affyplm")
+ (version "1.74.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "affyPLM" version))
+ (sha256
+ (base32 "0f0faxjzlg0znhjfvf1490yc54npkx659jx76cddm5hk7q0blv3v"))))
+ (properties `((upstream-name . "affyPLM")))
+ (build-system r-build-system)
+ (inputs (list zlib))
+ (propagated-inputs
+ (list r-affy
+ r-biobase
+ r-biocgenerics
+ r-gcrma
+ r-preprocesscore
+ r-zlibbioc))
+ (home-page "https://github.com/bmbolstad/affyPLM")
+ (synopsis "Methods for fitting probe-level models")
+ (description
+ "The affyPLM provides a package that extends and improves the
+functionality of the base affy package. For speeding up the runs, it includes
+routines that make heavy use of compiled code. The central focus is on
+implementation of methods for fitting probe-level models and tools using these
+models. @acronym{PLM, probe-level models} based quality assessment tools are
+also provided.")
+ (license license:gpl2+)))
+
(define-public r-affyrnadegradation
(package
(name "r-affyrnadegradation")
@@ -2617,6 +2707,57 @@ Powerful interactive and dynamic figures generated by animalcules enable users
to understand their data better and discover new insights.")
(license license:artistic2.0)))
+(define-public r-annotationhubdata
+ (package
+ (name "r-annotationhubdata")
+ (version "1.28.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "AnnotationHubData" version))
+ (sha256
+ (base32 "0mcx09kcxccw2gkf4c3w7sxgb7v3gwbvahvx9wgq8f93q85yzg95"))))
+ (properties `((upstream-name . "AnnotationHubData")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'install 'set-home
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list r-annotationdbi
+ r-annotationforge
+ r-annotationhub
+ r-biobase
+ r-bioccheck
+ r-biocgenerics
+ r-biocmanager
+ r-biocviews
+ r-biostrings
+ r-dbi
+ r-futile-logger
+ r-genomeinfodb
+ r-genomicfeatures
+ r-genomicranges
+ r-graph
+ r-iranges
+ r-jsonlite
+ r-organismdbi
+ r-rcurl
+ r-rsamtools
+ r-rsqlite
+ r-rtracklayer
+ r-s4vectors
+ r-xml))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/AnnotationHubData")
+ (synopsis "Transform public data resources into Bioconductor data structures")
+ (description
+ "This package provides tools to acquire, annotate, convert and store data
+for use in Bioconductor’s AnnotationHub.")
+ (license license:artistic2.0)))
+
(define-public r-anvil
(package
(name "r-anvil")
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ad6f92ba7b..33761933a3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2818,6 +2818,27 @@ designed to make it easy to install and load multiple tidyverse packages in a
single step.")
(license license:gpl3)))
+(define-public r-tkrplot
+ (package
+ (name "r-tkrplot")
+ (version "0.0-27")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tkrplot" version))
+ (sha256
+ (base32 "19bj4wn1fs4wrx5k4gakhpz4q59fgx0584wyaw7hnh0ljj8i34n9"))))
+ (properties `((upstream-name . "tkrplot")))
+ (build-system r-build-system)
+ (inputs (list libx11))
+ (home-page "https://cran.r-project.org/package=tkrplot")
+ (synopsis "Place R graphics in a Tk widget")
+ (description
+ "The tkrplot package lets you place R graphics in a @dfn{Tk,
+cross-platform graphical user interface toolkit} widget.")
+ ;; Any version of the GPL.
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-rvest
(package
(name "r-rvest")
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index c914ccc18e..98c37bd6ed 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1054,7 +1054,9 @@ new Date();"))
(find-files "." ".*.(bin|exe|jar)$"))))
(sha256
(base32
- "0i47ar8lxzjrkkiwbzybfxs473390h4jq9ahm3xqdvy5zpchxy3y"))))
+ "0i47ar8lxzjrkkiwbzybfxs473390h4jq9ahm3xqdvy5zpchxy3y"))
+ (patches (search-patches
+ "openjdk-10-idlj-reproducibility.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments openjdk9)
((#:phases phases)