aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-27 16:09:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:41 -0400
commitb7f1104f0f14cf9f187cc8e8b05224d34914380b (patch)
tree8683216029cb154e57fec81042a9e9ef63441804 /gnu
parent4f884cff29ac1480c4fa8123b6a229befbc6caa7 (diff)
downloadguix-b7f1104f0f14cf9f187cc8e8b05224d34914380b.tar
guix-b7f1104f0f14cf9f187cc8e8b05224d34914380b.tar.gz
gnu: qtwayland-5: Update to 5.15.8.
* gnu/packages/qt.scm (qtwayland-5): Update to 5.15.8. [arguments]: Use gexps.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm54
1 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 00e3bdbc3e..80317ef5ec 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1608,38 +1608,38 @@ set of plugins for interacting with pulseaudio and GStreamer.")
(license (package-license qtbase))))
(define-public qtwayland-5
- (package (inherit qtsvg-5)
+ (package
+ (inherit qtsvg-5)
(name "qtwayland")
- (version "5.15.5")
+ (version "5.15.8")
(source (origin
- (method url-fetch)
- (uri (qt-urls name version))
- (patches (search-patches "qtwayland-gcc-11.patch"
- "qtwayland-dont-recreate-callbacks.patch"
- "qtwayland-cleanup-callbacks.patch"))
- (sha256
- (base32
- "0yy8qf9kn15iqsxi2r7jbcsc0vsdyfz7bbxmfn4i9qmz1yvg0jgr"))))
+ (method url-fetch)
+ (uri (qt-urls name version))
+ (patches (search-patches "qtwayland-gcc-11.patch"
+ "qtwayland-dont-recreate-callbacks.patch"
+ "qtwayland-cleanup-callbacks.patch"))
+ (sha256
+ (base32
+ "0aa5jcvvap6qca6imdkhs1mhv5bnaxn466mmpl7x78jx1za7n3ps"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg-5)
((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- ;; FIXME: tst_seatv4::animatedCursor() fails for no good
- ;; reason and breaks these two tests.
- (substitute* "tests/auto/client/seatv4/tst_seatv4.cpp"
- (((string-append "QVERIFY\\(!cursorSurface\\(\\)->"
- "m_waitingFrameCallbacks\\.empty\\(\\)\\);"))
- "")
- (("QTRY_COMPARE\\(bufferSpy\\.count\\(\\), 1\\);")
- ""))))
- (add-before 'check 'set-test-environment
- (lambda _
- ;; Do not fail just because /etc/machine-id is missing.
- (setenv "DBUS_FATAL_WARNINGS" "0")))))))
- (native-inputs
- (list glib perl pkg-config qtdeclarative-5))
+ #~(modify-phases #$phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; FIXME: tst_seatv4::animatedCursor() fails for no good
+ ;; reason and breaks these two tests.
+ (substitute* "tests/auto/client/seatv4/tst_seatv4.cpp"
+ (((string-append "QVERIFY\\(!cursorSurface\\(\\)->"
+ "m_waitingFrameCallbacks\\.empty\\(\\)\\);"))
+ "")
+ (("QTRY_COMPARE\\(bufferSpy\\.count\\(\\), 1\\);")
+ ""))))
+ (add-before 'check 'set-test-environment
+ (lambda _
+ ;; Do not fail just because /etc/machine-id is missing.
+ (setenv "DBUS_FATAL_WARNINGS" "0")))))))
+ (native-inputs (list glib perl pkg-config qtdeclarative-5))
(inputs
(list fontconfig
freetype