aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-04-14 19:27:29 +0000
committerLudovic Courtès <ludo@gnu.org>2023-05-02 11:57:55 +0200
commit2667b838c891e491a848eedfb5c1699dc25afe21 (patch)
tree0245761ef1f58b5687737ad3ccbde32f31876bcc /gnu
parent9d9fd543042093748e330bab4070d51372c91dbe (diff)
downloadguix-2667b838c891e491a848eedfb5c1699dc25afe21.tar
guix-2667b838c891e491a848eedfb5c1699dc25afe21.tar.gz
gnu: dune-grid: Update to 2.9.0.
* gnu/packages/maths.scm (dune-grid): Update to 2.9.0. [source](patches): Add patch to fix build. * gnu/packages/patches/dune-grid-add-missing-include-cassert.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/maths.scm6
-rw-r--r--gnu/packages/patches/dune-grid-add-missing-include-cassert.patch24
3 files changed, 29 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index ebe5893373..2947f3ac6a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1056,6 +1056,7 @@ dist_patch_DATA = \
%D%/packages/patches/dovecot-trees-support-dovecot-2.3.patch \
%D%/packages/patches/dstat-fix-crash-when-specifying-delay.patch \
%D%/packages/patches/dstat-skip-devices-without-io.patch \
+ %D%/packages/patches/dune-grid-add-missing-include-cassert.patch \
%D%/packages/patches/dvd+rw-tools-add-include.patch \
%D%/packages/patches/dynaconf-unvendor-deps.patch \
%D%/packages/patches/efivar-211.patch \
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c9bd0a7718..7cf1308368 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6915,7 +6915,7 @@ This package contains the DUNE UG grid classes.")
(define-public dune-grid
(package
(name "dune-grid")
- (version "2.7.1")
+ (version "2.9.0")
(source
(origin
(method url-fetch)
@@ -6923,7 +6923,9 @@ This package contains the DUNE UG grid classes.")
version "/dune-grid-" version ".tar.gz"))
(sha256
(base32
- "15iws03hkbmr4a4rqqb0rriz1m8szl96wdr7gw0jmrcnlzbdbbx5"))))
+ "17l2vlr8q3rfifxv80r3jlzamx478xn0vfjkrl3ns1akk7miycq8"))
+ (patches (search-patches
+ "dune-grid-add-missing-include-cassert.patch"))))
(build-system cmake-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/patches/dune-grid-add-missing-include-cassert.patch b/gnu/packages/patches/dune-grid-add-missing-include-cassert.patch
new file mode 100644
index 0000000000..7462b11934
--- /dev/null
+++ b/gnu/packages/patches/dune-grid-add-missing-include-cassert.patch
@@ -0,0 +1,24 @@
+From ef843b1a66308247ba4d2e2c116ff5517421a91b Mon Sep 17 00:00:00 2001
+From: Simon Praetorius <simon.praetorius@tu-dresden.de>
+Date: Tue, 6 Dec 2022 13:39:44 +0100
+Subject: [PATCH] Add missing include <cassert>
+
+---
+ dune/grid/test/yasp/test-yaspgrid-partitioner.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/dune/grid/test/yasp/test-yaspgrid-partitioner.cc b/dune/grid/test/yasp/test-yaspgrid-partitioner.cc
+index 93ae042b0..9a4530201 100644
+--- a/dune/grid/test/yasp/test-yaspgrid-partitioner.cc
++++ b/dune/grid/test/yasp/test-yaspgrid-partitioner.cc
+@@ -6,6 +6,7 @@
+ #include <config.h>
+
+ #include <array>
++#include <cassert>
+ #include <iostream>
+
+ #include <dune/common/filledarray.hh>
+--
+2.39.2
+