aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-03-18 07:49:23 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-12 08:26:23 -0400
commit1bb45f61ed9aa9462400280ef5f384658d12754f (patch)
treedd9d36c3d512ecd4b6fb2be0c13852657e59b8f4 /gnu
parent62cc728619f40b6d165c4ca8757368b8f8cc40fc (diff)
downloadguix-1bb45f61ed9aa9462400280ef5f384658d12754f.tar
guix-1bb45f61ed9aa9462400280ef5f384658d12754f.tar.gz
gnu: Add python-imageio-ffmpeg.
* gnu/packages/python-xyz.scm (python-imageio-ffmpeg): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 01d478b6aa..3701ed5546 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8165,6 +8165,35 @@ converting, and viewing many of the proprietary file formats used to store
experimental data and metadata at the Laboratory for Fluorescence Dynamics.")
(license license:bsd-3)))
+(define-public python-imageio-ffmpeg
+ (package
+ (name "python-imageio-ffmpeg")
+ (version "0.4.8")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "imageio-ffmpeg" version))
+ (sha256
+ (base32
+ "1a8as5c42s8yl79gc2nhj6vvkwr81p5ibxp5m1zhn1zy22nhbapx"))))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'hardcode-ffmpeg
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "imageio_ffmpeg/_utils.py"
+ (("os\\.getenv\\(\"IMAGEIO_FFMPEG_EXE\".*\\)" all)
+ (string-append "(" all " or \""
+ (search-input-file inputs "bin/ffmpeg")
+ "\")"))))))))
+ (inputs (list ffmpeg-4))
+ (build-system python-build-system)
+ (home-page "https://github.com/imageio/imageio-ffmpeg")
+ (synopsis "FFMPEG wrapper for Python")
+ (description "This package provides an FFMPEG wrapper for working with video
+files. It implements generator functions for reading and writing data to and
+from FFMPEG, reliably terminating the process when done.")
+ (license license:bsd-2)))
+
(define-public python-imageio
(package
(name "python-imageio")