aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-03-22 11:19:19 -0400
committerMark H Weaver <mhw@netris.org>2014-03-22 11:19:19 -0400
commit1eefbb2693f0f29f8f095af9f067240b85e735aa (patch)
tree35dbaa90de4bb52162b176725aa6ac10d8de0e4f /gnu
parentb1a01474ac4f5bae1f2689805105103742178c2b (diff)
parent6212b8e5d3f08a3ff05111167f0b190cea800c7c (diff)
downloadguix-1eefbb2693f0f29f8f095af9f067240b85e735aa.tar
guix-1eefbb2693f0f29f8f095af9f067240b85e735aa.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm8
-rw-r--r--gnu/packages/algebra.scm11
-rw-r--r--gnu/packages/base.scm7
-rw-r--r--gnu/packages/cmake.scm26
-rw-r--r--gnu/packages/gnustep.scm71
-rw-r--r--gnu/packages/imagemagick.scm6
-rw-r--r--gnu/packages/lua.scm4
-rw-r--r--gnu/packages/lynx.scm10
-rw-r--r--gnu/packages/screen.scm8
-rw-r--r--gnu/packages/ssh.scm5
-rw-r--r--gnu/packages/xiph.scm11
-rw-r--r--gnu/packages/xorg.scm14
-rw-r--r--gnu/packages/zip.scm5
13 files changed, 154 insertions, 32 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index ffedfd3f44..89df1a9148 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -317,6 +318,13 @@ ONC RPC numbers")
(base32
"1frjcdkhkpzk0f84hx6hmw5l0ynpmji8vcbaxg8h5k2svyxz0nmm"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ ;; By default, man and info pages are put in PREFIX/{man,info},
+ ;; but we want them in PREFIX/share/{man,info}.
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "--mandir=" out "/share/man")
+ (string-append "--infodir=" out "/share/info")))))
(home-page "http://netcat.sourceforge.net")
(synopsis "Read and write data over TCP/IP")
(description
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index faab4edc85..a1564e000e 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -179,8 +180,14 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
(let ((out (assoc-ref outputs "out")))
(setenv "CONFIG_SHELL" (which "bash"))
(zero?
- (system* "./configure"
- (string-append "--prefix=" out)))))
+ (system*
+ "./configure"
+ (string-append "--prefix=" out)
+ ;; By default, man and info pages are put in
+ ;; PREFIX/{man,info}, but we want them in
+ ;; PREFIX/share/{man,info}.
+ (string-append "--mandir=" out "/share/man")
+ (string-append "--infodir=" out "/share/info")))))
%standard-phases)))
(home-page "http://www.gnu.org/software/bc/")
(synopsis "Arbitrary precision numeric processing language")
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 89d90c989b..1f6e86341f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -500,7 +501,7 @@ with the Linux kernel.")
(define-public tzdata
(package
(name "tzdata")
- (version "2013d")
+ (version "2014a")
(source (origin
(method url-fetch)
(uri (string-append
@@ -508,7 +509,7 @@ with the Linux kernel.")
version ".tar.gz"))
(sha256
(base32
- "011v63ppr73vhjgxv00inkn5pc7z48i8lhbapkpdq3kfczq9c76d"))))
+ "1cg843ajz4g16axpz56zvalwsbp1s764na2bk4fb44ayx162bzvw"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f
@@ -555,7 +556,7 @@ with the Linux kernel.")
version ".tar.gz"))
(sha256
(base32
- "1dh7nzmfxs8fps4bzcd2lz5fz24zxy2123a99avxsk34jh6bk7id"))))))
+ "1xfkqi1q8cnxqbv8azdj5pqlzhkjz6xag09f1z0s8rxi86jkpf85"))))))
(home-page "http://www.iana.org/time-zones")
(synopsis "Database of current and historical time zones")
(description "The Time Zone Database (often called tz or zoneinfo)
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 84873f4a3b..87a70decc7 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,7 +23,8 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
- #:use-module (gnu packages file))
+ #:use-module (gnu packages file)
+ #:use-module (srfi srfi-1))
(define-public cmake
(package
@@ -32,15 +34,15 @@
(method url-fetch)
(uri (string-append
"http://www.cmake.org/files/v"
- (substring version 0
- (string-index version #\. (+ 1 (string-index version #\.))))
+ (string-join (take (string-split version #\.) 2)
+ ".")
"/cmake-" version ".tar.gz"))
(sha256
(base32 "11q21vyrr6c6smyjy81k2k07zmn96ggjia9im9cxwvj0n88bm1fq"))
(patches (list (search-patch "cmake-fix-tests.patch")))))
(build-system gnu-build-system)
(arguments
- '(#:test-target "test"
+ `(#:test-target "test"
#:phases (alist-replace
'configure
(lambda* (#:key outputs #:allow-other-keys)
@@ -61,8 +63,20 @@
"Utilities/cmlibarchive/libarchive/archive_write_set_format_shar.c"
"Tests/CMakeLists.txt")
(("/bin/sh") (which "sh")))
- (zero? (system* "./configure"
- (string-append "--prefix=" out)))))
+ (zero? (system*
+ "./configure"
+ (string-append "--prefix=" out)
+ ;; By default, the man pages and other docs land
+ ;; in PREFIX/man and PREFIX/doc, but we want them
+ ;; in share/{man,doc}. Note that unlike
+ ;; autoconf-generated configure scripts, cmake's
+ ;; configure prepends "PREFIX/" to what we pass
+ ;; to --mandir and --docdir.
+ "--mandir=share/man"
+ ,(string-append
+ "--docdir=share/doc/cmake-"
+ (string-join (take (string-split version #\.) 2)
+ "."))))))
%standard-phases)))
(inputs
`(("file" ,file)))
diff --git a/gnu/packages/gnustep.scm b/gnu/packages/gnustep.scm
new file mode 100644
index 0000000000..8584ba6096
--- /dev/null
+++ b/gnu/packages/gnustep.scm
@@ -0,0 +1,71 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gnustep)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix licenses)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages libjpeg)
+ #:use-module (gnu packages pkg-config))
+
+(define-public windowmaker
+ (package
+ (name "windowmaker")
+ (version "0.95.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://windowmaker.org/pub/source/release/WindowMaker-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1l3hmx4jzf6vp0zclqx9gsqrlwh4rvqm1g1zr5ha0cp0zmsg89ab"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (alist-cons-after
+ 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
+ ;; which in turn wants to invoke 'wmmenugen' etc., so
+ ;; make sure everything is in $PATH.
+ (wrap-program (string-append bin "/wmaker")
+ `("PATH" ":" prefix (,bin)))))
+ %standard-phases)))
+ (inputs
+ `(("libxmu" ,libxmu)
+ ("libxft" ,libxft)
+ ("libx11" ,libx11)
+ ("fontconfig" ,fontconfig)
+ ("libjpeg" ,libjpeg)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://windowmaker.org/")
+ (synopsis "NeXTSTEP-like window manager")
+ (description
+ "Window Maker is an X11 window manager originally designed to provide
+integration support for the GNUstep Desktop Environment. In every way
+possible, it reproduces the elegant look and feel of the NeXTSTEP user
+interface. It is fast, feature rich, easy to configure, and easy to use.")
+
+ ;; Artwork is distributed under the WTFPL.
+ (license gpl2+)))
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index a1713273e9..e8869ddfd5 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,14 +37,14 @@
(define-public imagemagick
(package
(name "imagemagick")
- (version "6.8.8-4")
+ (version "6.8.8-8")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "0bfxhfymkdbvardlr0nbjfmv53m47lcl9kkycipk4hxawfs927jr"))))
+ "1b1j4j6gyxd02nm7v70d8prjvh09dk9klralrr8avm9ys1wqd7r4"))))
(build-system gnu-build-system)
(arguments
`(#:phases (alist-cons-before
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 81caa263ad..8394afb641 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -66,13 +66,13 @@ for configuration, scripting, and rapid prototyping.")
(define-public luajit
(package
(name "luajit")
- (version "2.0.2")
+ (version "2.0.3")
(source (origin
(method url-fetch)
(uri (string-append "http://luajit.org/download/LuaJIT-"
version ".tar.gz"))
(sha256
- (base32 "0f3cykihfdn3gi6na9p0xjd4jnv26z18m441n5vyg42q9abh4ln0"))))
+ (base32 "0ydxpqkmsn2c341j4r2v6r5r0ig3kbwv3i9jran3iv81s6r6rgjm"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ;luajit is distributed without tests
diff --git a/gnu/packages/lynx.scm b/gnu/packages/lynx.scm
index a87316643d..ebca50d34f 100644
--- a/gnu/packages/lynx.scm
+++ b/gnu/packages/lynx.scm
@@ -33,13 +33,15 @@
(define-public lynx
(package
(name "lynx")
- (version "2.8.8")
+ (version "2.8.8rel.2")
(source (origin
(method url-fetch)
- (uri (string-append "http://lynx.isc.org/lynx" version
- "/lynx" version ".tar.bz2"))
+ (uri (string-append
+ "http://lynx.isc.org/lynx"
+ (substring version 0 (string-index version char-set:letter))
+ "/lynx" version ".tar.bz2"))
(sha256
- (base32 "00jcfmx4bxnrzywzzlllz3z45a2mc4fl91ca5lrzz1pyr1s1qnm2"))))
+ (base32 "1rxysl08acqll5b87368f04kckl8sggy1qhnq59gsxyny1ffg039"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("perl" ,perl)))
diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index bb11c58fc1..58ee42a2a2 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -39,6 +40,13 @@
(inputs
`(("ncurses", ncurses)
("perl" ,perl)))
+ (arguments
+ `(#:configure-flags
+ ;; By default, man and info pages are put in PREFIX/{man,info},
+ ;; but we want them in PREFIX/share/{man,info}.
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "--mandir=" out "/share/man")
+ (string-append "--infodir=" out "/share/info")))))
(home-page "http://www.gnu.org/software/screen/")
(synopsis "Full-screen window manager providing multiple terminals")
(description
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 6bf68a916e..43c1b6e90b 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -121,14 +122,14 @@ a server that supports the SSH-2 protocol.")
(define-public openssh
(package
(name "openssh")
- (version "6.5p1")
+ (version "6.6p1")
(source (origin
(method url-fetch)
(uri (string-append
"ftp://ftp.fr.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-"
version ".tar.gz"))
(sha256 (base32
- "09wh7mi65aahyxd2xvq1makckhd5laid8c0pb8njaidrbpamw6d1"))))
+ "1fq3w86q05y5nn6z878wm312k0svaprw8k007188fd259dkg1ha8"))))
(build-system gnu-build-system)
(inputs `(("groff" ,groff)
("openssl" ,openssl)
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 0e8cb5fafc..2de9074f28 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -80,7 +81,8 @@ periodic timestamps for seeking.")
"1gby6hapz9njx4l9g0pndyk4q83z5fgrgc30mfwfgx7bllspsk43"))))
(build-system gnu-build-system)
(propagated-inputs `(("libogg" ,libogg)))
- (arguments `(#:configure-flags '("LDFLAGS=-lm")))
+ (arguments `(#:configure-flags '("LDFLAGS=-lm")
+ #:parallel-tests? #f))
(synopsis "libvorbis, a library implementing the vorbis audio format")
(description
"The libvorbis library implements the ogg vorbis audio format,
@@ -201,7 +203,12 @@ OpenBSD's sndio.")
(list (search-patch "flac-fix-memcmp-not-declared.patch")))))
(build-system gnu-build-system)
(arguments
- `(#:parallel-tests? #f))
+ `(#:parallel-tests? #f
+ ;; By default, man pages are put in PREFIX/man,
+ ;; but we want them in PREFIX/share/man.
+ #:configure-flags (list (string-append "--mandir="
+ (assoc-ref %outputs "out")
+ "/share/man"))))
;; FIXME: configure also looks for xmms, input could be added once it exists
(inputs `(("libogg" ,libogg)))
(synopsis "flac free lossless audio codec")
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 13da10d7cb..2e1eeda245 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1260,13 +1260,13 @@ tracking.")
"1gdv6559cdz1lfw73x7wsvax1fkvphmayrymprljhyyb5nwk5kkz"))))
(build-system gnu-build-system)
(propagated-inputs
- ;; xft.pc refers to 'xrender'.
- `(("libxrender" ,libxrender)))
- (inputs
- `(("libx11" ,libx11)
- ("xproto" ,xproto)
+ ;; xft.pc refers to all these.
+ `(("libxrender" ,libxrender)
("freetype" ,freetype)
("fontconfig" ,fontconfig)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("xproto" ,xproto)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "http://www.x.org/wiki/")
@@ -4731,14 +4731,14 @@ icccm: Both client and window-manager helpers for ICCCM.")
(define-public xterm
(package
(name "xterm")
- (version "301")
+ (version "303")
(source (origin
(method url-fetch)
(uri ; XXX: constant URL!
"http://invisible-island.net/datafiles/release/xterm.tar.gz")
(sha256
(base32
- "040rarvv18zg0lk7qy0m3n7gv10mh40jic708wvng01z4rlbpfhz"))))
+ "0n7hay16aam9kfn642ri0wj5yzilbjm3l8znxc2p5dx9pn3rkwla"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-wide-chars" "--enable-256-color"
diff --git a/gnu/packages/zip.scm b/gnu/packages/zip.scm
index c0fd8c519e..03f3bc22ea 100644
--- a/gnu/packages/zip.scm
+++ b/gnu/packages/zip.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -89,7 +90,9 @@ Compression ratios of 2:1 to 3:1 are common for text files.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))
(copy-file "unix/Makefile" "Makefile")
- (substitute* "Makefile" (("/usr/local") out))))
+ (substitute* "Makefile"
+ (("/usr/local") out)
+ (("/man/") "/share/man/"))))
%standard-phases)))
(home-page "http://www.info-zip.org/UnZip.html")
(synopsis "Unzip decompression and file extraction utility")