aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2016-12-24 22:53:07 -0500
committerLudovic Courtès <ludo@gnu.org>2016-12-31 01:44:04 +0100
commit0f391063d9a96fb99d11c2ddbddd040527746bc4 (patch)
treea95ac027df98fd58e9fcc26cddf92b6852b0f361 /gnu
parent987a29ba43cc8a2751eafe392906d240713c724e (diff)
downloadguix-0f391063d9a96fb99d11c2ddbddd040527746bc4.tar
guix-0f391063d9a96fb99d11c2ddbddd040527746bc4.tar.gz
gnu: pius: Update to 2.2.2-0.891687c.
* gnu/packages/gnupg.scm (pius): Update to 2.2.2-0.891687c. [inputs]: Change GNUPG-2.0 to GNUPG (2.1). Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnupg.scm72
1 files changed, 41 insertions, 31 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 5d5a6cdff0..167d9ace8c 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016 Mike Gerwitz <mtg@gnu.org>
+;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,6 +49,7 @@
#:use-module (gnu packages tls)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python))
@@ -460,35 +462,43 @@ and signature functionality from Python programs.")
(package-with-python2 python-gnupg))
(define-public pius
- (package
- (name "pius")
- (version "2.2.2")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/jaymzh/pius/releases/download/v"
- version "/pius-" version ".tar.bz2"))
- (sha256
- (base32
- "0k94mlr7l12mplph7pdgjbampqha47d8mfjq69n4xm80qwbn1rq1"))))
- (build-system python-build-system)
- (inputs `(("perl" ,perl) ;for 'pius-party-worksheet'
- ("gpg" ,gnupg-2.0))) ;2.1 fails to talk to gpg-agent 2.0
- (arguments
- `(#:tests? #f
- #:python ,python-2 ;uses the Python 2 'print' syntax
- #:phases
- (modify-phases %standard-phases
- (add-before
- 'build 'set-gpg-file-name
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((gpg (string-append (assoc-ref inputs "gpg")
- "/bin/gpg")))
- (substitute* "libpius/constants.py"
- (("/usr/bin/gpg2") gpg))))))))
- (synopsis "Programs to simplify GnuPG key signing")
- (description
- "Pius (PGP Individual UID Signer) helps attendees of PGP keysigning
+ ;; pius 2.2.2 does not work with gpg-agent 2.1, so we take a newer
+ ;; commit. When a new pius (> 2.2.2) is released, update this package
+ ;; and delete this message.
+ ;; More info: https://github.com/jaymzh/pius/issues/46
+ (let ((commit "891687ccb3d232a1fc0e7da7d22572c0318644cb")
+ (base-version "2.2.2")) ; i.e. there were no releases
+ ; between BASE-VERSION and COMMIT
+ (package
+ (name "pius")
+ (version (string-append base-version "-0."
+ (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaymzh/pius.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0m2na4bnf1rv0zpf404l9ga6pwyf7ijldp4lw5irgh7gkmpllxr3"))))
+ (build-system python-build-system)
+ (inputs `(("perl" ,perl) ;for 'pius-party-worksheet'
+ ("gpg" ,gnupg)))
+ (arguments
+ `(#:tests? #f
+ #:python ,python-2 ;uses the Python 2 'print' syntax
+ #:phases
+ (modify-phases %standard-phases
+ (add-before
+ 'build 'set-gpg-file-name
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((gpg (string-append (assoc-ref inputs "gpg")
+ "/bin/gpg")))
+ (substitute* "libpius/constants.py"
+ (("/usr/bin/gpg2") gpg))))))))
+ (synopsis "Programs to simplify GnuPG key signing")
+ (description
+ "Pius (PGP Individual UID Signer) helps attendees of PGP keysigning
parties. It is the main utility and makes it possible to quickly and easily
sign each UID on a set of PGP keys. It is designed to take the pain out of
the sign-all-the-keys part of PGP Keysigning Party while adding security
@@ -496,8 +506,8 @@ to the process.
pius-keyring-mgr and pius-party-worksheet help organisers of
PGP keysigning parties.")
- (license license:gpl2)
- (home-page "https://www.phildev.net/pius/index.shtml")))
+ (license license:gpl2)
+ (home-page "https://www.phildev.net/pius/index.shtml"))))
(define-public signing-party
(package