aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-15 17:42:22 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-15 17:55:36 +0100
commit444464ec28fe63a8162d6b7d8ef5b408082df91b (patch)
treeb8310408b9cad6a0948b9abfe48255e7c1076248 /gnu
parent6f976df6771a3eb90c3b16de45a861856bcde52e (diff)
downloadguix-444464ec28fe63a8162d6b7d8ef5b408082df91b.tar
guix-444464ec28fe63a8162d6b7d8ef5b408082df91b.tar.gz
gnu: python-rpy2: Fix tests.
* gnu/packages/python.scm (python-rpy2, python2-rpy2)[arguments]: Replace check phase with custom post-install command.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 610785bc59..f79073470a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3674,6 +3674,16 @@ operators such as union, intersection, and difference.")
(base32
"0nhan2qvrw7b7gg5zddwa22kybdv3x1g26vkd7q8lvnkgzrs4dga"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; It's easier to run tests after install.
+ ;; Make installed package available for running the tests
+ (add-installed-pythonpath inputs outputs)
+ (zero? (system* "python" "-m" "rpy2.tests" "-v")))))))
(propagated-inputs
`(("python-six" ,python-six)))
(inputs