aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-11-19 23:28:14 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-12-18 22:16:41 +0100
commit59fa09e1cd812613ebf01e901f6fdedbc65619ab (patch)
treef14e32b96a4d4c1f4b04993da26e069a0b6bc372 /gnu
parenteffc8325a5c1aa07ca6cf13e864010ea67d24898 (diff)
downloadguix-59fa09e1cd812613ebf01e901f6fdedbc65619ab.tar
guix-59fa09e1cd812613ebf01e901f6fdedbc65619ab.tar.gz
gnu: ocaml-ppx-tools-versioned: Use dune-build-system.
* gnu/packages/ocaml.scm (ocaml-ppx-tools-versioned): Use dune-build-system. Remove duplicate definition.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm55
1 files changed, 2 insertions, 53 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ed087b7298..23ca26652f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1592,60 +1592,9 @@ functions to the next and/or previous version.")
(sha256
(base32
"1x2xfjpkzbcz4rza1d7gh3ipliw6jqfcklbsln82v3561qgkqgmh"))))
- (build-system ocaml-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda _
- (invoke "dune" "build" "@install")
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "dune" "install"
- "--prefix" (assoc-ref outputs "out"))
- #t)))))
- (native-inputs
- `(("dune" ,dune)))
- (propagated-inputs
- `(("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)))
- (home-page "https://github.com/let-def/ppx_tools_versioned")
- (synopsis "Variant of ppx_tools")
- (description "This package is a variant of ppx_tools based on
-ocaml-migrate-parsetree")
- (license license:expat)))
-
-(define-public ocaml-ppx-tools-versioned
- (package
- (name "ocaml-ppx-tools-versioned")
- (version "5.2.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ocaml-ppx/"
- "ppx_tools_versioned/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1x2xfjpkzbcz4rza1d7gh3ipliw6jqfcklbsln82v3561qgkqgmh"))))
- (build-system ocaml-build-system)
+ (build-system dune-build-system)
(arguments
- `(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda _
- (invoke "dune" "build" "@install")
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "dune" "install"
- "--prefix" (assoc-ref outputs "out"))
- #t)))))
- (native-inputs
- `(("dune" ,dune)))
+ `(#:test-target "."))
(propagated-inputs
`(("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)))
(home-page "https://github.com/let-def/ppx_tools_versioned")