aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 15:49:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:57 +0100
commitb6fc288e57883d835aef6da1608a17a5de6ef3c9 (patch)
treebc6d7d57251201f3392e5e16bc3641a2df8706d9 /gnu
parentabe50aa369d43e95966c12146f542f44d5fef8d1 (diff)
downloadguix-b6fc288e57883d835aef6da1608a17a5de6ef3c9.tar
guix-b6fc288e57883d835aef6da1608a17a5de6ef3c9.tar.gz
gnu: Add python-send2trash.
* gnu/packages/python.scm (python-send2trash, python2-send2trash): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f2b24481ef..59a3f1364b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4888,6 +4888,28 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(define-public python2-ipykernel
(package-with-python2 python-ipykernel))
+(define-public python-send2trash
+ (package
+ (name "python-send2trash")
+ (version "1.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "send2trash" version))
+ (sha256
+ (base32
+ "1ci8vcwjmjlp11ljj1ckrfmml9fkq1mclx2gr53y4zvhgp01q030"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/hsoft/send2trash")
+ (synopsis "Send files to trash")
+ (description
+ "This package provides a cross-platform mechanism to send files to the
+trash.")
+ (license license:bsd-3)))
+
+(define-public python2-send2trash
+ (package-with-python2 python-send2trash))
+
;; This is the latest release of the LTS version of ipython with support for
;; Python 2.7 and Python 3.x. Later non-LTS versions starting from 6.0 have
;; dropped support for Python 2.7. We may want to rename this package.