aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-22 15:18:13 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit7cfdbc514f5b558cdae16e87f66774bd033fbc6d (patch)
treed7e50ee4adbb89037c4f6f8e99e6f0db3954f6f7 /gnu
parent3f2ce1dc3f070bb1cc24616cd56b3ab66b67af80 (diff)
downloadguix-7cfdbc514f5b558cdae16e87f66774bd033fbc6d.tar
guix-7cfdbc514f5b558cdae16e87f66774bd033fbc6d.tar.gz
gnu: Add ghc-tasty.
* gnu/packages/haskell.scm (ghc-tasty): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b8d2e0ad7c..8c1e6f799d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2831,4 +2831,36 @@ functions for breaking or splitting on substrings and replacing all
occurrences of a substring (the first in case of overlaps) with another.")
(license bsd-3)))
+(define-public ghc-tasty
+ (package
+ (name "ghc-tasty")
+ (version "0.11.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/tasty/tasty-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1chapivmmwsb1ghwagvdm80bfj3hdk75m94z4p212ng2i4ghpjkx"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-stm" ,ghc-stm)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-tagged" ,ghc-tagged)
+ ("ghc-regex-tdfa-rc" ,ghc-regex-tdfa-rc)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-unbounded-delays" ,ghc-unbounded-delays)
+ ("ghc-async" ,ghc-async)
+ ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ ("ghc-clock-bootstrap" ,ghc-clock-bootstrap)))
+ (home-page "http://documentup.com/feuerbach/tasty")
+ (synopsis "Modern and extensible testing framework")
+ (description "Tasty is a modern testing framework for Haskell. It lets
+you combine your unit tests, golden tests, QuickCheck/SmallCheck properties,
+and any other types of tests into a single test suite.")
+ (license expat)))
+
;;; haskell.scm ends here