aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2019-07-24 20:21:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 23:05:38 +0200
commit6deb08a35933714a1713406c2e81522bfb2c3401 (patch)
tree616a3e1906e1b0d838a0dd01f2d507f79ba86853 /gnu
parent1c0b2e7483f50017911097d6b555e266461c9e85 (diff)
downloadguix-6deb08a35933714a1713406c2e81522bfb2c3401.tar
guix-6deb08a35933714a1713406c2e81522bfb2c3401.tar.gz
gnu: Add r-kableextra.
* gnu/packages/cran.scm (r-kableextra): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 675d6596d1..1383ab067f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14554,3 +14554,42 @@ easily.")
dimension reduction. This package provides an interface to the UMAP algorithm
in R, including a translation of the original algorithm into R.")
(license license:expat)))
+
+(define-public r-kableextra
+ (package
+ (name "r-kableextra")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "kableExtra" version))
+ (sha256
+ (base32
+ "1nicvw06xsf3a1f5c10mih07b76m2v5s5h165vmz0qx6n1a3492i"))))
+ (properties `((upstream-name . "kableExtra")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-digest" ,r-digest)
+ ("r-glue" ,r-glue)
+ ("r-htmltools" ,r-htmltools)
+ ("r-knitr" ,r-knitr)
+ ("r-magrittr" ,r-magrittr)
+ ("r-readr" ,r-readr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-rvest" ,r-rvest)
+ ("r-scales" ,r-scales)
+ ("r-stringr" ,r-stringr)
+ ("r-viridislite" ,r-viridislite)
+ ("r-webshot" ,r-webshot)
+ ("r-xml2" ,r-xml2)))
+ (home-page "https://haozhu233.github.io/kableExtra/")
+ (synopsis "Construct complex tables with pipe syntax")
+ (description
+ "Build complex HTML or LaTeX tables using @code{kable()} from
+@code{knitr} and the piping syntax from @code{magrittr}. The function
+@code{kable()} is a light weight table generator coming from @code{knitr}.
+This package simplifies the way to manipulate the HTML or LaTeX codes
+generated by @code{kable()} and allows users to construct complex tables and
+customize styles using a readable syntax.")
+ (license license:expat)))