aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2016-05-26 01:31:30 +0200
committerAlex Kost <alezost@gmail.com>2016-05-27 11:02:54 +0300
commitd345491ab4896dcf4f492bc4c8c7df2387991071 (patch)
treeca007a65518943ce2ff7eab8279768c6b5ab6dc5 /gnu
parenta8ce82aca236fa6e6c05f90d6751a151ec2c93e6 (diff)
downloadguix-d345491ab4896dcf4f492bc4c8c7df2387991071.tar
guix-d345491ab4896dcf4f492bc4c8c7df2387991071.tar.gz
gnu: Add emacs-epl.
* gnu/packages/emacs.scm (emacs-epl): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7d14db3d1e..5d6db5ae11 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1684,3 +1684,25 @@ well as completely new features.")
refactoring for the @uref{http://clojure.org, Clojure programming language}.
It is recommended to use @code{clojure-mode} with paredit or smartparens.")
(license license:gpl3+)))
+
+(define-public emacs-epl
+ (package
+ (name "emacs-epl")
+ (version "0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/cask/epl/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1511n3a3f5gvaf2b4nh018by61ciyzi3y3603fzqma7p9hrckarc"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/cask/epl")
+ (synopsis "Emacs Package Library")
+ (description
+ "A package management library for Emacs, based on @code{package.el}.
+
+The purpose of this library is to wrap all the quirks and hassle of
+@code{package.el} into a sane API.")
+ (license license:gpl3+)))