aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:13:29 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:18 +0300
commitca0e2ab00a2cce29a1814e5aeebdeae8f09af59f (patch)
tree59192dedd6076e4703fd6697f561acf3464776f1 /gnu
parent0e087b704f719ad9dcc7a97c3916cda3e66d3547 (diff)
downloadguix-ca0e2ab00a2cce29a1814e5aeebdeae8f09af59f.tar
guix-ca0e2ab00a2cce29a1814e5aeebdeae8f09af59f.tar.gz
gnu: Add emacs-wordgen.
* gnu/packages/emacs.scm (emacs-wordgen): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index cc3d2fcc4a..fdcd769052 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10011,3 +10011,23 @@ bookmarks and history.")
(synopsis "Makes ido-mode display vertically")
(description "Makes ido-mode display prospects vertically.")
(license license:gpl3+)))
+
+(define-public emacs-wordgen
+ (package
+ (name "emacs-wordgen")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/Fanael/wordgen.el/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1h2iyixdm49h53pwj9ics9gb9h3g6wa4hainpnjg6mfarf49jkmg"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Fanael/wordgen.el")
+ (synopsis "Random word generator")
+ (description "This package provides functions to generate random words
+using user-provided rules.")
+ (license license:gpl3+)))