aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-04-15 12:52:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-04-15 12:52:41 +0200
commit732825f3f8ddc123db3ddf9ff066379adeed8471 (patch)
treee390ee4067e73fac84e161a34bb5429ed9a3212a /gnu
parente0cfc3739698da4d683d8d5bcae1e144665c68c7 (diff)
downloadguix-732825f3f8ddc123db3ddf9ff066379adeed8471.tar
guix-732825f3f8ddc123db3ddf9ff066379adeed8471.tar.gz
gnu: efibootmgr: Update to 16.
* gnu/packages/linux.scm (efibootmgr): Update to 16. [arguments]: Add EFIDIR to #:make-flags. Remove related 'branding' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 29b75e9b10..34df4a2134 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3850,7 +3850,7 @@ interface to the variable facility of UEFI boot firmware.")
(define-public efibootmgr
(package
(name "efibootmgr")
- (version "14")
+ (version "16")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/rhinstaller/" name
@@ -3858,26 +3858,23 @@ interface to the variable facility of UEFI boot firmware.")
"-" version ".tar.bz2"))
(sha256
(base32
- "1n3sydvpr6yl040hhf460k7mrxby7laqd9dqs6pq0js1hijc2zip"))))
+ "0pzn67vxxaf7jna4cd0i4kqm60h04kb21hckksv9z82q9gxra1wm"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No tests.
#:make-flags (list (string-append "prefix=" %output)
(string-append "libdir=" %output "/lib")
+ ;; EFIDIR denotes a subdirectory relative to the
+ ;; EFI System Partition where the loader will be
+ ;; installed (known as OS_VENDOR in the code).
+ ;; GRUB overrides this, as such it's only used if
+ ;; nothing else is specified on the command line.
+ "EFIDIR=gnu"
;; Override CFLAGS to add efivar include directory.
(string-append "CFLAGS=-O2 -g -flto -I"
(assoc-ref %build-inputs "efivar")
"/include/efivar"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'branding
- ;; Replace default loader path with something more familiar.
- (lambda _
- (substitute* "src/efibootmgr.c"
- (("EFI\\\\\\\\redhat") ; Matches 'EFI\\redhat'.
- "EFI\\\\gnu"))
- #t))
- (delete 'configure))))
+ #:phases (modify-phases %standard-phases (delete 'configure))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs