aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-03 22:15:33 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-06-05 08:37:17 +0300
commit3fef2a9dd9350a35422add588a0ce7b02c88675e (patch)
treebd70648bf12029ff11c87ef3987106a357fdc2a4 /gnu
parentd8bc8245a6c5a5d70ba827cc514c21cf0362d2b9 (diff)
downloadguix-3fef2a9dd9350a35422add588a0ce7b02c88675e.tar
guix-3fef2a9dd9350a35422add588a0ce7b02c88675e.tar.gz
gnu: Add emacs-dante.
* gnu/packages/emacs-xyz.scm (emacs-dante): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3b91639979..77ff792016 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -667,6 +667,37 @@ programs.")
(define-public haskell-mode
(deprecated-package "haskell-mode" emacs-haskell-mode))
+(define-public emacs-dante
+ (let ((commit "149dded24ca9cdff09a3d859e4b62638db4aadda")
+ (revision "1"))
+ (package
+ (name "emacs-dante")
+ (version (git-version "1.5" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jyp/dante")
+ (commit commit)))
+ (sha256
+ (base32
+ "0i7kj3d6pfys6si9va5f36qzifyac9mahdl0qh40rya9m0syrkla"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-haskell-mode" ,emacs-haskell-mode)
+ ("emacs-s" ,emacs-s)
+ ("emacs-company" ,emacs-company)
+ ("emacs-lcr" ,emacs-lcr)))
+ (home-page "https://github.com/jyp/dante")
+ (synopsis "Minor mode for interactive Haskell")
+ (description
+ "This package provides a minor mode for Haskell development that
+supports type hints, definition-jumping, completion, and more.")
+ (license license:gpl3+))))
+
(define-public emacs-flycheck
(package
(name "emacs-flycheck")