aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-15 11:53:02 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-15 11:53:02 +0200
commit09ba396c02405eac12215fd2d5d535a70a75c158 (patch)
tree9b68bd2176675b1314c01ea7415a5538f8cdb223 /gnu
parent5c860cec8329cbcf68504791c01b6ebd0571e783 (diff)
downloadguix-09ba396c02405eac12215fd2d5d535a70a75c158.tar
guix-09ba396c02405eac12215fd2d5d535a70a75c158.tar.gz
gnu: Remove dependency from gzip to the bootstrap binaries.
* gnu/packages/base.scm (grep-final): New variable. (%boot5-inputs): Add it. (%final-inputs): Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index bbeee3f0cd..f14baa9409 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1160,9 +1160,19 @@ store.")
;; test files in Gettext.
#:guile guile-final)))
+(define grep-final
+ ;; The final grep. Gzip holds a reference to it (via zgrep), so it must be
+ ;; built before gzip.
+ (package-with-bootstrap-guile
+ (package-with-explicit-inputs grep
+ %boot4-inputs
+ (current-source-location)
+ #:guile guile-final)))
+
(define %boot5-inputs
;; Now use the final Coreutils.
`(("coreutils" ,coreutils-final)
+ ("grep" ,grep-final)
,@%boot4-inputs))
(define-public %final-inputs
@@ -1183,9 +1193,9 @@ store.")
("diffutils" ,diffutils)
("patch" ,patch)
("sed" ,sed)
- ("grep" ,grep)
("findutils" ,findutils)
("gawk" ,gawk)))
+ ("grep" ,grep-final)
("coreutils" ,coreutils-final)
("make" ,gnu-make-final)
("bash" ,bash-final)