aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-27 00:43:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-27 00:49:23 +0200
commit8ac8b3b3601560c4a455543435276a8cdf61b54e (patch)
tree0873524e3de592106debe95090c4059d253d2ed1 /gnu
parent996aca2852b97570988eb6d7371f15fcedd16e46 (diff)
downloadguix-8ac8b3b3601560c4a455543435276a8cdf61b54e.tar
guix-8ac8b3b3601560c4a455543435276a8cdf61b54e.tar.gz
gnu: lollypop: Wrap with required path variables.
Fixes <https://issues.guix.info/issue/37937>. * gnu/packages/gnome.scm (lollypop)[arguments]: Rename ‘wrap’ phase to ‘wrap-python’ and add ‘wrap-glib-or-gtk’ phase. [inputs]: Add gsettings-desktop-schemas.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8bb891bfb3..12993eadef 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7809,8 +7809,10 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
(wrap-program (string-append out "/bin/lollypop")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
#t))
- (add-after 'install 'wrap
- (@@ (guix build python-build-system) wrap)))))
+ (add-after 'install 'wrap-python
+ (@@ (guix build python-build-system) wrap))
+ (add-after 'install 'wrap-glib-or-gtk
+ (@@ (guix build glib-or-gtk-build-system) wrap-all-programs)))))
(native-inputs
`(("intltool" ,intltool)
("itstool" ,itstool)
@@ -7819,6 +7821,7 @@ views can be printed as PDF or PostScript files, or exported to HTML.")
("pkg-config" ,pkg-config)))
(inputs
`(("gobject-introspection" ,gobject-introspection)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gst-plugins-base" ,gst-plugins-base)
("libnotify" ,libnotify)
("libsecret" ,libsecret)