aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:44:10 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:18 +0000
commitb29207c2cd46bdc5d78e8d801eeb0aef35ee8c16 (patch)
tree9dcfce186a9ad721515f307c75f4b7c123d0f07b /gnu
parentc3e37e5b73fb7a9052a351131f9f2ffa3958b9a3 (diff)
downloadguix-b29207c2cd46bdc5d78e8d801eeb0aef35ee8c16.tar
guix-b29207c2cd46bdc5d78e8d801eeb0aef35ee8c16.tar.gz
gnu: Add ruby-webmock.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index cea020a87c..7036d12c77 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5004,6 +5004,33 @@ support to both Ruby and JRuby. It uses @code{unf_ext} on CRuby and
"https://github.com/janlelis/ruby_version")
(license license:expat)))
+(define-public ruby-webmock
+ (package
+ (name "ruby-webmock")
+ (version "1.22.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "webmock" version))
+ (sha256
+ (base32
+ "0la47vzbikhvnx8qcj8jli87agzzffwh11ggm7rpq43iz2rwp0sl"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("bundler" ,bundler)
+ ("ruby-addressable" ,ruby-addressable)
+ ("ruby-crack" ,ruby-crack)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-hashdiff" ,ruby-hashdiff)))
+ (synopsis
+ "WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.")
+ (description
+ "WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.")
+ (home-page "http://github.com/bblimke/webmock")
+ (license license:expat)))
+
(define-public ruby-domain-name
(package
(name "ruby-domain-name")