aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:35:19 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:18 +0000
commit887b6ceef9485c98980562768bb4382afdbe14e7 (patch)
tree84807ff52723609befd74c1aaa198146a4c0e89f /gnu
parent7078bcd75680862f971fc454c787f6be2871f345 (diff)
downloadguix-887b6ceef9485c98980562768bb4382afdbe14e7.tar
guix-887b6ceef9485c98980562768bb4382afdbe14e7.tar.gz
gnu: Enable tests for ruby-addressable.
* gnu/packages/ruby.scm (ruby-addressable): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm53
1 files changed, 38 insertions, 15 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9bc1595ea5..2cffde31a0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5850,23 +5850,46 @@ all known public suffixes.")
(package
(name "ruby-addressable")
(version "2.5.2")
- (source (origin
- (method url-fetch)
- (uri (rubygems-uri "addressable" version))
- (sha256
- (base32
- "0viqszpkggqi8hq87pqp0xykhvz60g99nwmkwsb0v45kc2liwxvk"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "addressable" version))
+ (sha256
+ (base32
+ "0viqszpkggqi8hq87pqp0xykhvz60g99nwmkwsb0v45kc2liwxvk"))))
(build-system ruby-build-system)
- (propagated-inputs
- `(("ruby-public-suffix" ,ruby-public-suffix)))
(arguments
- ;; No test target
- `(#:tests? #f))
- (home-page "https://github.com/sporkmonger/addressable")
- (synopsis "Alternative URI implementation")
- (description "Addressable is a replacement for the URI implementation that
-is part of Ruby's standard library. It more closely conforms to RFC 3986,
-RFC 3987, and RFC 6570 (level 4), providing support for IRIs and URI templates.")
+ '(#:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-rakefile
+ (lambda _
+ (substitute* "Gemfile"
+ (("git: 'https://github.com/sporkmonger/rack-mount.git',") "")
+ ((".*launchy.*") "")
+ ((".*rake.*") "gem 'rake'\n")
+ ((".*redcarpet.*") ""))
+ #t))
+ (add-before 'check 'delete-network-test
+ (lambda _
+ (delete-file "spec/addressable/net_http_compat_spec.rb")
+ #t)))))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)
+ ("bundler" ,bundler)
+ ("ruby-idn-ruby" ,ruby-idn-ruby)
+ ("ruby-public-suffix" ,ruby-public-suffix)
+ ("ruby-sporkmonger-rack-mount" ,ruby-sporkmonger-rack-mount)
+ ("ruby-rspec-its", ruby-rspec-its)
+ ("ruby-yard" ,ruby-yard)
+ ("ruby-simplecov" ,ruby-simplecov)))
+ (synopsis "Uniform resource identifier (URI) reimplementation")
+ (description
+ "Addressable is a replacement for the URI implementation that is part of
+Ruby's standard library. It more closely conforms to the relevant RFCs and
+adds support for IRIs and URI templates.")
+ (home-page
+ "https://github.com/sporkmonger/addressable")
(license license:asl2.0)))
(define-public ruby-colorator