aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:58:33 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-28 11:21:18 +0000
commit1e2502fbc1000988c79a6bf9cc5eefcf98e95afe (patch)
treeb30b1f87fd18520edf141cf2345e0ba9003f3ce7 /gnu
parenta89d258f8e824d1f2626e9c5fef77895f75eab6d (diff)
downloadguix-1e2502fbc1000988c79a6bf9cc5eefcf98e95afe.tar
guix-1e2502fbc1000988c79a6bf9cc5eefcf98e95afe.tar.gz
gnu: Add ruby-racc.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index dc993053f0..07ff366522 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3777,6 +3777,41 @@ differences (added or removed nodes) between two XML/HTML documents.")
(home-page "https://github.com/postmodern/nokogiri-diff")
(license license:expat))))
+(define-public ruby-racc
+ (package
+ (name "ruby-racc")
+ (version "1.4.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "racc" version))
+ (sha256
+ (base32
+ "00yhs2ag7yy5v83mqvkbnhk9bvsh6mx3808k53n61ddzx446v1zl"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; tests fail to compile
+ (native-inputs
+ `(("ruby-hoe" ,ruby-hoe)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis
+ "Racc is a LALR(1) parser generator.
+ It is written in Ruby itself, and generates Ruby program.
+
+ NOTE: Ruby 1.8.x comes with Racc runtime module. You
+ can run your parsers generated by racc 1.4.x out of the
+ box.")
+ (description
+ "Racc is a LALR(1) parser generator.
+ It is written in Ruby itself, and generates Ruby program.
+
+ NOTE: Ruby 1.8.x comes with Racc runtime module. You
+ can run your parsers generated by racc 1.4.x out of the
+ box.")
+ (home-page
+ "http://i.loveruby.net/en/projects/racc/")
+ (license license:expat)))
+
(define-public ruby-rack
(package
(name "ruby-rack")