aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2018-01-30 15:16:33 +0100
committerLudovic Courtès <ludo@gnu.org>2018-01-30 16:21:43 +0100
commit4b0bf9909774d47ca21ff3b537a0895c1209aa5e (patch)
treee2021fe2d3132f43808a8989c0f3f2cf0d8f5a6d /gnu
parentadbe6dea33b66624b8f6d0e60fa091991c8c5e25 (diff)
downloadguix-4b0bf9909774d47ca21ff3b537a0895c1209aa5e.tar
guix-4b0bf9909774d47ca21ff3b537a0895c1209aa5e.tar.gz
gnu: fftw: Add version 3.3.7.
* gnu/packages/algebra.scm (fftw-3.3.7): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 5ec7f94d2d..2c508b6e35 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2013, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
@@ -516,6 +516,7 @@ a C program.")
(license license:bsd-3)))
(define-public fftw
+ ;; TODO: Make this 3.3.7 (see below) on the next upgrade cycle.
(package
(name "fftw")
(version "3.3.5")
@@ -575,6 +576,19 @@ cosine/ sine transforms or DCT/DST).")
(string-append (package-description fftw)
" With OpenMPI parallelism support."))))
+(define-public fftw-3.3.7
+ ;; TODO: Make this the default 'fftw' on the next upgrade cycle.
+ (package
+ (inherit fftw)
+ (version "3.3.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://ftp.fftw.org/pub/fftw/fftw-"
+ version".tar.gz"))
+ (sha256
+ (base32
+ "0wsms8narnbhfsa8chdflv2j9hzspvflblnqdn7hw8x5xdzrnq1v"))))))
+
(define-public eigen
(package
(name "eigen")