aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-11-28 08:52:26 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:42 +0000
commitf7fabe82cbeb72eeff2892d839ffa8ef9eba3633 (patch)
treeedc45ee93cdb42b47503c431c68c996c0b95317e /gnu
parent7d46ec3e7af66196ed9f9a3e6ff120b369871915 (diff)
downloadguix-f7fabe82cbeb72eeff2892d839ffa8ef9eba3633.tar
guix-f7fabe82cbeb72eeff2892d839ffa8ef9eba3633.tar.gz
gnu: python-joblib: Update to 1.4.2.
* gnu/packages/python-xyz.scm (python-joblib): Update to 1.4.2. [arguments]<#:test-flags>: Add --numprocesses flag. [native-inputs]: Add python-pytest-xdist. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 899f93c80b..d8ae0b6d20 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6889,19 +6889,22 @@ bookmarks using a declarative input in the form of a markdown file.")
(define-public python-joblib
(package
(name "python-joblib")
- (version "1.3.2")
+ (version "1.4.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "joblib" version))
(sha256
(base32
- "1cbjjzsh9hzaqr2cqja95673p7j88b8bd02hjpkq8xz147k6by4j"))))
+ "03izdcvc3fa355cclzgvzmjnfwylvblz9q091b9gndi6df0wb0i3"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags ; disabled to avoid having to depend on ipython/jupyter
- #~(list "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
- (native-inputs (list python-pytest python-setuptools python-wheel))
+ #~(list
+ "--numprocesses" (number->string (parallel-job-count))
+ "-k" "not test_parallel_call_cached_function_defined_in_jupyter")))
+ (native-inputs
+ (list python-pytest python-pytest-xdist python-setuptools python-wheel))
(propagated-inputs (list python-psutil))
(home-page "https://joblib.readthedocs.io/")
(synopsis "Using Python functions as pipeline jobs")
@@ -6912,7 +6915,6 @@ and lazy re-evaluation (memoize pattern), easy simple parallel computing
logging and tracing of the execution.")
(license license:bsd-3)))
-
(define-public python-daemon
(package
(name "python-daemon")