aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-12-16 00:06:33 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-12-16 00:14:34 +0800
commit65892d9f20aa7a8649797507bb1ec867285083fb (patch)
tree9b50feea739bd7e3d528dccee6b9a156832bab45 /gnu
parente1143622ed40d9d6a3ec9dfd319b678f824487ec (diff)
downloadguix-65892d9f20aa7a8649797507bb1ec867285083fb.tar
guix-65892d9f20aa7a8649797507bb1ec867285083fb.tar.gz
gnu: python-sentry-sdk: Fix build.
* gnu/packages/python-xyz.scm (python-sentry-sdk)[arguments]<#:phases>: Add fix-test phase. Skip test_threading and test_transport test. Change-Id: Iee8e3909d8e581eb6fbe5e45a103645409094888
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7004338de2..ec71a6b614 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15007,6 +15007,14 @@ you do not want to store entirely on disk or on memory.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-before 'check 'fix-test
+ ;; See https://github.com/getsentry/sentry-python/pull/2712
+ (lambda _
+ (substitute* "tests/__init__.py"
+ (("import pytest")
+ "import warnings")
+ (("pytest.warns\\(None\\)")
+ "warnings.catch_warnings(record=True)"))))
(replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
@@ -15061,7 +15069,12 @@ you do not want to store entirely on disk or on memory.")
" and not test_finds_transaction_when_descendent_span_is_on_scope"
" and not test_finds_orphan_span_on_scope"
" and not test_finds_non_orphan_span_on_scope"
- " and not test_circular_references"))))))))
+ " and not test_circular_references"
+
+ ;; AttributeError: module 'py' has no attribute 'process'
+ ;; See <https://github.com/pytest-dev/pytest-forked/issues/88>.
+ " and not test_threading"
+ " and not test_transport"))))))))
(native-inputs
(list python-django
python-executing