aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-29 15:20:51 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:36 +0000
commit35a6ca06605b0252e88f117488e3d8070f870a63 (patch)
tree60561009c606296418747ae3f227456df874940c /gnu
parenta33c8eadd090c91011ea4fa78eed0ea7a6135a78 (diff)
downloadguix-35a6ca06605b0252e88f117488e3d8070f870a63.tar
guix-35a6ca06605b0252e88f117488e3d8070f870a63.tar.gz
gnu: python-snowballstemmer: Update to 2.2.0.
* gnu/packages/python-xyz.scm (python-snowballstemmer): Update to 2.2.0. Improve style. [build-system]: Swap to pyproject-build-system. [arguments]<tests>: Switch them off as not provided. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ifbef2578990eb4a3e3a498922de8852fadbdc5b7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 19 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5a138d18ee..e1e6875132 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24014,25 +24014,31 @@ numbers, real numbers, mixed types and more, and comes with a shell command
between the different Python versions.")
(license license:psfl)))
+;; XXX: The last time updated in 2015, consider to remove it when nothing is
+;; depend on it.
(define-public python-snowballstemmer
(package
(name "python-snowballstemmer")
- (version "2.0.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "snowballstemmer" version))
- (sha256
- (base32
- "0ligk61idlz8kkgd5hpip5whm172riwglb6xydii7h62yhysqfyz"))))
- (build-system python-build-system)
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "snowballstemmer" version))
+ (sha256
+ (base32 "1ccwy75i0f5yi1vy6fyvr1gf43ydhjani45mswm43ls7hpmnvc89"))))
+ (build-system pyproject-build-system)
(arguments
- `(;; No tests exist
- #:tests? #f))
+ (list
+ #:tests? #f)) ; no tests
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
(home-page "https://github.com/shibukawa/snowball_py")
(synopsis "Snowball stemming library collection for Python")
- (description "This package provides 16 word stemmer algorithms generated
- from Snowball algorithms. It includes the 15 original ones plus the Poerter
- English stemmer.")
+ (description
+ "This package provides 16 word stemmer algorithms generated from Snowball
+algorithms. It includes the 15 original ones plus the Poerter English
+stemmer.")
(license license:bsd-3)))
(define-public python-setproctitle