aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-15 20:09:51 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-15 20:09:51 +0200
commite6e09dc9c53df38e48be331a5f930ef6d52454f4 (patch)
tree954c55383a6be58e8b96fe0fa8af685c55257fab /gnu
parent5ba856aba340d85744cedcfeeb34319cb778de11 (diff)
downloadguix-e6e09dc9c53df38e48be331a5f930ef6d52454f4.tar
guix-e6e09dc9c53df38e48be331a5f930ef6d52454f4.tar.gz
gnu: sooperlooper: Adjust for GCC 7.
* gnu/packages/music.scm (sooperlooper)[arguments]: Remove <#:make-flags>. Preserve CPATH in <#:phases>.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a2c2e01661..9119817056 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2942,8 +2942,7 @@ with a number of bugfixes and changes to improve IT playback.")
(patches (search-patches "sooperlooper-build-with-wx-30.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "CXXFLAGS=-std=gnu++11")
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'add-sigc++-includes
(lambda* (#:key inputs #:allow-other-keys)
@@ -2955,7 +2954,8 @@ with a number of bugfixes and changes to improve IT playback.")
sig "/lib/sigc++-2.0/include:"
xml "/include/libxml2/:"
cwd "/libs/pbd:"
- cwd "/libs/midi++")))
+ cwd "/libs/midi++:"
+ (or (getenv "CPATH") ""))))
(substitute* '("src/control_osc.hpp"
"src/gui/app_frame.hpp"
"src/gui/config_panel.hpp"