aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-05-15 15:26:46 +0800
committer宋文武 <iyzsong@gmail.com>2016-05-28 07:29:10 +0800
commitde477809d77393b8fb00d99cd35d65f77d157726 (patch)
treeb33a13e1a46bffe60774f8b2079badb9bd31bb61 /gnu
parent1a6d3cd374bcff136592e04caa0dafada3352ecd (diff)
downloadguix-de477809d77393b8fb00d99cd35d65f77d157726.tar
guix-de477809d77393b8fb00d99cd35d65f77d157726.tar.gz
gnu: wxmaxima: Wrap with GSETTINGS_SCHEMA_DIR and XDG_DATA_DIRS.
Fixes <http://bugs.gnu.org/22709> and <http://bugs.gnu.org/23260>. * gnu/packages/math.scm (wxmaxima)[arguments]: Wrap with GSETTINGS_SCHEMA_DIR and XDG_DATA_DIRS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 80e48ca58d..e11208c32e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1610,7 +1610,11 @@ point numbers.")
(build-system gnu-build-system)
(inputs
`(("wxwidgets" ,wxwidgets)
- ("maxima" ,maxima)))
+ ("maxima" ,maxima)
+ ;; Runtime support.
+ ("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("gtk+" ,gtk+)
+ ("shared-mime-info" ,shared-mime-info)))
(arguments
`(#:phases (modify-phases %standard-phases
(add-after
@@ -1620,7 +1624,18 @@ point numbers.")
"/bin/wxmaxima")
`("PATH" ":" prefix
(,(string-append (assoc-ref inputs "maxima")
- "/bin"))))
+ "/bin")))
+ ;; For GtkFileChooserDialog.
+ `("GSETTINGS_SCHEMA_DIR" =
+ (,(string-append (assoc-ref inputs "gtk+")
+ "/share/glib-2.0/schemas")))
+ `("XDG_DATA_DIRS" ":" prefix
+ (;; Needed by gdk-pixbuf to know supported icon formats.
+ ,(string-append
+ (assoc-ref inputs "shared-mime-info") "/share")
+ ;; The default icon theme of GTK+.
+ ,(string-append
+ (assoc-ref inputs "adwaita-icon-theme") "/share"))))
#t)))))
(home-page "https://andrejv.github.io/wxmaxima/")
(synopsis "Graphical user interface for the Maxima computer algebra system")