aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-23 16:38:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-23 23:15:54 +0200
commit57be09b207f8691ea303fce9c6d76c892e3fed13 (patch)
tree22ad799ca91634c50e5e438609aae2ab4d0cff0d /gnu
parenta17e1b9e11022c8ff478464916654dbdef38a032 (diff)
downloadguix-57be09b207f8691ea303fce9c6d76c892e3fed13.tar
guix-57be09b207f8691ea303fce9c6d76c892e3fed13.tar.gz
gnu: python-utils: Update to 2.4.0.
* gnu/packages/python-xyz.scm (python-utils): Update to 2.4.0. [arguments]: Replace check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 10cf27dbd7..a88865ed43 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14187,14 +14187,22 @@ exception message with a traceback that points to the culprit.")
(define-public python-utils
(package
(name "python-utils")
- (version "2.1.0")
+ (version "2.4.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "python-utils" version))
(sha256
(base32
- "1mcsy6q5am4ya72rgkpb6kax6vv7c93cfkkas89xnpa4sj9zf28p"))))
+ "12c0glzkm81ljgf6pwh0d4rmdm1r7vvgg3ifzp8yp9cfyngw07zj"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (delete-file "pytest.ini")
+ (invoke "pytest" "-vv"))))))
(native-inputs
`(("pytest-runner" ,python-pytest-runner)
("pytest" ,python-pytest)