aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-12-04 20:15:45 +0100
committerTimothy Sample <samplet@ngyro.com>2020-12-06 21:35:41 -0500
commit0c86b24c41e63e852b8cab4d5b6b643fa76ad870 (patch)
tree16f45154dfd5cdb7ba60822041e91d4430e638e7 /gnu
parent897f47bc6abb88820244fb23ceba75bb9f7c705d (diff)
downloadguix-0c86b24c41e63e852b8cab4d5b6b643fa76ad870.tar
guix-0c86b24c41e63e852b8cab4d5b6b643fa76ad870.tar.gz
gnu: Add hledger-web.
* gnu/packages/finance.scm (hledger-web): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index a79c70d1e0..b19d28c123 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1648,3 +1649,54 @@ generate a variety of reports from them, and provides a web interface.")
(synopsis "Emacs mode for beancount")
(description
"Emacs-beancount is an Emacs mode for the Beancount accounting tool.")))
+
+(define-public hledger-web
+ (package
+ (name "hledger-web")
+ (version "1.14.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hledger-web/hledger-web-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0w59nr7mj0nx8z44cvhy1rhlj5rmx0wq4p5nfl4dycfmp7jwvsm1"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-decimal" ,ghc-decimal)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-blaze-markup" ,ghc-blaze-markup)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-clientsession" ,ghc-clientsession)
+ ("ghc-cmdargs" ,ghc-cmdargs)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-data-default" ,ghc-data-default)
+ ("ghc-hjsmin" ,ghc-hjsmin)
+ ("hledger" ,hledger)
+ ("ghc-hledger-lib" ,ghc-hledger-lib)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-http-conduit" ,ghc-http-conduit)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-json" ,ghc-json)
+ ("ghc-megaparsec" ,ghc-megaparsec)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-shakespeare" ,ghc-shakespeare)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-wai-extra" ,ghc-wai-extra)
+ ("ghc-wai-handler-launch" ,ghc-wai-handler-launch)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-yaml" ,ghc-yaml)
+ ("ghc-yesod" ,ghc-yesod)
+ ("ghc-yesod-core" ,ghc-yesod-core)
+ ("ghc-yesod-form" ,ghc-yesod-form)
+ ("ghc-yesod-static" ,ghc-yesod-static)))
+ (home-page "https://hledger.org")
+ (synopsis "Web-based user interface for the hledger accounting system")
+ (description "This package provides a simple Web-based User
+Interface (UI) for the hledger accounting system. It can be used as a
+local, single-user UI, or as a multi-user UI for viewing, adding, and
+editing on the Web.")
+ (license license:gpl3)))