aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 16:59:46 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:24 +0200
commit431abc6e47e06c7a1e9063560be1e2ab52f793ee (patch)
treeb32f8ce1473dd54018665f122a4f95623705d3ee /gnu
parentba5de732529a4b71a58e3516386f03a36e8964c3 (diff)
downloadguix-431abc6e47e06c7a1e9063560be1e2ab52f793ee.tar
guix-431abc6e47e06c7a1e9063560be1e2ab52f793ee.tar.gz
gnu: Add rust-foreign-types-0.3.
* gnu/packages/crates-io.scm (rust-foreign-types-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6c2c58927c..a1b7ea6aae 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1663,6 +1663,32 @@ implementation that is more efficient for smaller hash keys.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-foreign-types-0.3
+ (package
+ (name "rust-foreign-types")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "foreign-types" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1cgk0vyd7r45cj769jym4a6s7vwshvd0z4bqrb92q1fwibmkkwzn"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-foreign-types-macros" ,rust-foreign-types-macros-0.1)
+ ("rust-foreign-types-shared" ,rust-foreign-types-shared-0.1))))
+ (home-page "https://github.com/sfackler/foreign-types")
+ (synopsis "Framework for Rust wrappers over C APIs")
+ (description
+ "This package provides a framework for Rust wrappers over C
+APIs.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-foreign-types-macros-0.1
(package
(name "rust-foreign-types-macros")