aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-18 12:14:32 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-01 11:46:19 +0200
commit6499b70ebf8f0de3c0d4741f573e6fe4768c2ef6 (patch)
tree9fb98e55ceea1cd605cc4b9c6646bced359ea306 /gnu
parentec67294611aec69d9f6077656355ec7e3c25d4ae (diff)
downloadguix-6499b70ebf8f0de3c0d4741f573e6fe4768c2ef6.tar
guix-6499b70ebf8f0de3c0d4741f573e6fe4768c2ef6.tar.gz
gnu: Add r-ztable.
* gnu/packages/statistics.scm (r-ztable): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 1b114b35bb..0c6c0173eb 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2046,3 +2046,24 @@ directly from R. Once uploaded to a plotly account, plotly graphs (and the
data behind them) can be viewed and modified in a web browser.")
(license license:x11)))
+
+(define-public r-ztable
+ (package
+ (name "r-ztable")
+ (version "0.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ztable" version))
+ (sha256
+ (base32
+ "1jfqnqy9544gfvz3bsb48v4177nwp4b4n9l2743asq8sbq305b5r"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/ztable")
+ (synopsis "Zebra-striped tables in LaTeX and HTML formats for R")
+ (description
+ "This package provides functions to make zebra-striped tables (tables
+with alternating row colors) in LaTeX and HTML formats easily from
+@code{data.frame}, @code{matrix}, @code{lm}, @code{aov}, @code{anova},
+@code{glm}, @code{coxph}, @code{nls}, @code{fitdistr}, @code{mytable} and
+@code{cbind.mytable} objects.")
+ (license license:gpl2+)))