aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-22 18:11:08 -0400
committerMark H Weaver <mhw@netris.org>2016-04-04 12:32:59 -0400
commit2fc629ddc4580e081127f661c4b463e11b6e3dee (patch)
treeaa19de601389f1fa07210d9f12cc738840bb26f7 /gnu
parent4f363e73f8ab537786e6036c796ad20bebc76a97 (diff)
downloadguix-2fc629ddc4580e081127f661c4b463e11b6e3dee.tar
guix-2fc629ddc4580e081127f661c4b463e11b6e3dee.tar.gz
gnu: python-pyopenssl: Update to 16.0.0.
* gnu/packages/python.scm (python-pyopenssl, python2-pyopenssl): Update to 16.0.0. [arguments]: Remove field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c6f30ca1d3..150fce9540 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5912,7 +5912,7 @@ message digests and key derivation functions.")
(define-public python-pyopenssl
(package
(name "python-pyopenssl")
- (version "0.15.1")
+ (version "16.0.0")
(source
(origin
(method url-fetch)
@@ -5920,29 +5920,8 @@ message digests and key derivation functions.")
"pyOpenSSL/pyOpenSSL-" version ".tar.gz"))
(sha256
(base32
- "0wnnq15rhj7fhdcd8ycwiw6r6g3w9f9lcy6cigg8226vsrq618ph"))))
+ "0zfijaxlq4vgi6jz0d4i5xq9ygqnyps6br7lmigjhqnh8gp10g9n"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-tests
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "OpenSSL/test/test_ssl.py"
- (("client\\.connect\\(\\('verisign\\.com', 443\\)\\)")
- "return True")
- ;; FIXME: disable broken test
- (("test_set_tmp_ecdh") "disabled__set_tmp_ecdh"))
- (substitute* "OpenSSL/test/test_crypto.py"
- (("command = b\"openssl \"")
- (string-append "command = b\""
- (assoc-ref inputs "openssl")
- "/bin/openssl" " \""))
- ;; FIXME: disable four broken tests
- (("test_der") "disabled__der")
- (("test_digest") "disabled__digest")
- (("test_get_extension") "disabled__get_extension")
- (("test_extension_count") "disabled__extension_count"))
- #t)))))
(propagated-inputs
`(("python-cryptography" ,python-cryptography)
("python-six" ,python-six)))