aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 16:11:59 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:26 +0300
commitcff62457cc0a522a70270423015145ec294e7446 (patch)
treef33694fe76ea2941a5573ee3512c43c137a7e929 /gnu
parente3997ad79712f2c08f5fe23c1744456ac8d0eedf (diff)
downloadguix-cff62457cc0a522a70270423015145ec294e7446.tar
guix-cff62457cc0a522a70270423015145ec294e7446.tar.gz
gnu: Add go-github-com-godbus-dbus.
* gnu/packages/golang.scm (go-github-com-godbus-dbus): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1c5464c309..3040eefac0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages base)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -5485,3 +5486,28 @@ and @code{ioutil} packages that is easy to test.")
(description "Package @code{xdg} provides functions related to
@uref{freedesktop.org}.")
(license license:expat)))
+
+(define-public go-github-com-godbus-dbus
+ (package
+ (name "go-github-com-godbus-dbus")
+ (version "5.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/godbus/dbus")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bkc904073k807yxg6mvqaxrr6ammmhginr9p54jfb55mz3hfw3s"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:tests? #f ;no /var/run/dbus/system_bus_socket
+ #:import-path "github.com/godbus/dbus"))
+ (native-inputs
+ `(("dbus" ,dbus))) ;dbus-launch
+ (home-page "https://github.com/godbus/dbus/")
+ (synopsis "Native Go client bindings for the D-Bus")
+ (description "@code{dbus} is a library that implements native Go client
+bindings for the D-Bus message bus system.")
+ (license license:bsd-2)))