aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:00:10 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:10 +0300
commit4024607561d04899769a9ee98b1d23d1c2c3aef1 (patch)
tree648d9ca10d5550177d30329e4011754bb9249409 /gnu
parent3677e5ee1fed3402e9a424ef4601780bc75c55b8 (diff)
downloadguix-4024607561d04899769a9ee98b1d23d1c2c3aef1.tar
guix-4024607561d04899769a9ee98b1d23d1c2c3aef1.tar.gz
gnu: Add emacs-m-buffer-el.
* gnu/packages/emacs.scm (emacs-m-buffer-el): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fb69094b9c..60daf19948 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8712,3 +8712,32 @@ confused by comments or @code{foo-bar} matching @code{foo}.")
(description
"This package provides an edit server to respond to requests from Emacs.")
(license license:gpl3+)))
+
+(define-public emacs-m-buffer-el
+ (package
+ (name "emacs-m-buffer-el")
+ (version "0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/phillord/m-buffer-el"
+ "/archive/" "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "17vdcc8q37q9db98jyww1c0ivinmwfcw4l04zccfacalra63a214"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (zero? (system* "emacs" "--batch" "-L" "."
+ "-l" "test/m-buffer-test.el"
+ "-l" "test/m-buffer-at-test.el"
+ "-f" "ert-run-tests-batch-and-exit")))))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/phillord/m-buffer-el")
+ (synopsis "List oriented buffer operations for Emacs")
+ (description "@code{m-buffer} provides a set of list-orientated functions
+for operating over the contents of Emacs buffers.")
+ (license license:gpl3+)))